Illumos and xvm

Added by Jason Frank over 3 years ago

I know it's not really a help request, but hopefully someone will find it useful.

Looks like Illumos' kernel and xvm dom0 code aren't playing together nicely. I get an assertion error during boot. I've got BE's from before I installed xvm, but they're not accessible to me because the zpool level has been upgraded past what they support.

So, I cloned my snv_134a xvm BE, and tried to remove xvm from it.

I ran the following commands:

pkg uninstall urlgrabber xvmstore header-xvm libvirt vdiskadm virtinst virt-manager ipagent (your list could easily be different...)
Rebooted to my 134a xvm BE, and ran:
root@bads:~# beadm mount snv_134a_no_xvm /mnt
root@bads:~# pkg -R /mnt uninstall driver/xvm/pv

That last one wasn't listed as a dependency of anything else, I found it by searching my local packages for xvm...

I figured the last one was the money shot, but when I went to reboot, the kernel could not find /boot/$ISADIR/xen.gz.

To fix that, edit /rpool/boot/grub/menu.lst

Make sure you don't have the following line in your LIBBE entry:

kernel$ /boot/$ISADIR/xen.gz

Mine now looks like this:

title snv_134a_no_xvm
findroot (pool_rpool,0,a)
bootfs rpool/ROOT/snv_134a_no_xvm
splashimage /boot/solaris.xpm
foreground d25f00
background 115d93
kernel$ /platform/i86pc/kernel/$ISADIR/unix -B $ZFS-BOOTFS,console=graphics
module$ /platform/i86pc/$ISADIR/boot_archive

This appears to boot up fine.

I'll report back once I've gotten things reinstalled.