Project

General

Profile

Bug #10050

Installing package "cc" should automatically install package "system/header"

Added by Hubert Garavel about 2 years ago. Updated over 1 year ago.

Status:
Resolved
Priority:
Normal
Assignee:
-
Category:
-
Target version:
-
Start date:
2018-12-07
Due date:
% Done:

0%

Estimated time:
Difficulty:
Medium
Tags:
needs-triage

Description

By default

pkg install cc

installs a C compiler that fails to compiler the "hello world" program, because
file /usr/include/stdio.h (among others) is missing. This is confusing for novice
users.

To solve the issue, the user must also

pkg install system/header

This should be done automatically when installing package "cc", i.e.,
"cc" should depend on "system/header".

#1

Updated by Alexander Pyhalov almost 2 years ago

  • Status changed from New to Resolved
#2

Updated by Hubert Garavel over 1 year ago

I am not sure the problem is solved. In OpenIndiana 2019.05, installing package "cc" does not install "system/header".

So, the issue should be reopened.

#3

Updated by Michal Nowak over 1 year ago

Hubert Garavel wrote:

I am not sure the problem is solved. In OpenIndiana 2019.05, installing package "cc" does not install "system/header".

So, the issue should be reopened.

https://github.com/OpenIndiana/oi-userland/pull/5090

Also available in: Atom PDF