Bug #10169

Can not Install GCC-8 on freshly patched 2018.10 Hipster

Added by Jason Grove 20 days ago. Updated 5 days ago.

Status:ResolvedStart date:2019-01-01
Priority:NormalDue date:
Assignee:Alexander Pyhalov% Done:

100%

Category:OI-Userland
Target version:Hipster
Difficulty:Medium Tags:

Description

Created a new VM using the OI-hipster-gui-20181023 iso. After installing it I ran:

pkg update -v --be-name p20181231

After the reboot, I tried to install GCC-8 with :

pkg install developer/gcc-8

and it produced this error:

  1. pkg install developer/gcc-8
    Creating Plan (Checking for conflicting actions): |
    Traceback (most recent call last):
    File "/usr/bin/pkg", line 5678, in handle_errors
    _ret = func(args, **kwargs)
    File "/usr/bin/pkg", line 5664, in main_func
    pargs=pargs, **opts)
    File "/usr/bin/pkg", line 2123, in install
    display_plan_cb=display_plan_cb, logger=logger)
    File "/usr/lib/python2.7/vendor-packages/pkg/client/client_api.py", line 1558, in _install
    logger=logger)
    File "/usr/lib/python2.7/vendor-packages/pkg/client/client_api.py", line 1446, in __api_op
    logger=logger, **kwargs)
    File "/usr/lib/python2.7/vendor-packages/pkg/client/client_api.py", line 1317, in __api_plan
    display_plan_cb=display_plan_cb)
    File "/usr/lib/python2.7/vendor-packages/pkg/client/client_api.py", line 1289, in __api_plan
    for pd in api_plan_func(
    *kwargs):
    File "/usr/lib/python2.7/vendor-packages/pkg/client/api.py", line 1525, in __plan_op
    log_op_end_all=True)
    File "/usr/lib/python2.7/vendor-packages/pkg/client/api.py", line 1153, in __plan_common_exception
    six.reraise(exc_type, exc_value, exc_traceback)
    File "/usr/lib/python2.7/vendor-packages/pkg/client/api.py", line 1459, in __plan_op
    self._img.make_install_plan(**kwargs)
    File "/usr/lib/python2.7/vendor-packages/pkg/client/image.py", line 4353, in make_install_plan
    reject_list=reject_list)
    File "/usr/lib/python2.7/vendor-packages/pkg/client/image.py", line 4334, in __make_plan_common
    self.
    _call_imageplan_evaluate(ip)
    File "/usr/lib/python2.7/vendor-packages/pkg/client/image.py", line 4247, in _call_imageplan_evaluate
    ip.evaluate()
    File "/usr/lib/python2.7/vendor-packages/pkg/client/imageplan.py", line 3249, in evaluate
    self.
    _merge_actions()
    File "/usr/lib/python2.7/vendor-packages/pkg/client/imageplan.py", line 3925, in _merge_actions
    self.
    _find_all_conflicts()
    File "/usr/lib/python2.7/vendor-packages/pkg/client/imageplan.py", line 2807, in __find_all_conflicts
    gone_fmris, fmri_dict)
    File "/usr/lib/python2.7/vendor-packages/pkg/client/imageplan.py", line 2441, in __update_act
    assert act.attrs[act.key_attr] == key
    AssertionError

pkg: This is an internal error in pkg(5) version fdaa5606. Please log a
Service Request about this issue including the information above and this
message.

Of interest, I had a different VM that I installed last night that I Installed gcc-8 before doing a full update and it installed correctly. So I created another VM from the same ISO, patched it, and it too failed to install with the same error above. I then reverted back to the initial BE, destroyed the patched BE and then gcc-8 installed in the original BE.


Related issues

Duplicated by OpenIndiana Distribution - Bug #10203: Can't install cvs and essential-build Closed 2019-01-10

History

#1 Updated by Rich Lowe 19 days ago

  • Category changed from tools - gate/build tools to PKG (Image Packaging System)
  • Project changed from illumos gate to OpenIndiana Distribution

#2 Updated by Michal Nowak 19 days ago

The pkg version shipped in the ISO ought to be package/pkg@0.5.11,5.11-2018.0.0.5306:20181019T103031Z, the failing one package/pkg@0.5.11,5.11-2018.0.0.5309:20181123T142742Z.

The difference being these three patches committed on Nov 23, 2018: https://github.com/OpenIndiana/pkg5/commits/oi. Though src/client.py is not present in the traceback.

#4 Updated by Michal Nowak 11 days ago

  • Duplicated by Bug #10203: Can't install cvs and essential-build added

#5 Updated by Andy Fiddaman 10 days ago

I can't replicate this in a freshly installed OpenIndiana-text
I will re-try with OI-hipster-gui

#6 Updated by Jason Grove 10 days ago

I was able to replicate it in fresh install of openindiana-text tonight. Used the same procedure above, with this ISO: http://dlc.openindiana.org/isos/hipster/latest/OI-hipster-text-20181023.iso

#7 Updated by Andy Fiddaman 10 days ago

That's interesting. Turns out that my test system was building with oi-hipster-minimal, I'll re-test with -text. That would suggest that the problem is actually in a package that is in -text but not -minimal.

#8 Updated by Andy Fiddaman 10 days ago

The problem is being caused by the text/gnu-grep package which contains this line in its manifest.

license 3e7ce9223a3d638f969ee023155c70c84b28b396 license="GPLv3, FDLv1.3 "

Presumably the spaces are causing the traceback and pkg should be fixed.

To confirm, the following works:

af@hipster:~$ pfexec pkg change-facet version-lock.text/gnu-grep=false
af@hipster:~$ pfexec pkg update pkg://openindiana.org/text/gnu-grep@3.1
af@hipster:~$ pfexec pkg install gcc-8

#9 Updated by Michal Nowak 10 days ago

  • Category changed from PKG (Image Packaging System) to OI-Userland
  • Tags deleted (needs-triage)
  • Target version set to Hipster
  • Assignee set to Michal Nowak

#10 Updated by Michal Nowak 9 days ago

  • Assignee changed from Michal Nowak to Alexander Pyhalov
  • % Done changed from 0 to 100

#11 Updated by Jason Grove 7 days ago

Appears to have fixed my issue. I tried a new install of the text ISO and it worked there after patching. I also patched a pre-existing gui install and gcc-8 installed successfully on it as well. Thanks for the quick fix!

#12 Updated by Michal Nowak 5 days ago

  • Status changed from New to Resolved

Also available in: Atom