Feature #10173

loader: support newer ZFS versions

Added by Toomas Soome about 2 months ago. Updated about 1 month ago.

Status:ClosedStart date:2019-01-04
Priority:NormalDue date:
Assignee:Toomas Soome% Done:

100%

Category:bootloader
Target version:-
Difficulty:Bite-size Tags:

Description

This change did trigger my attention: https://svnweb.freebsd.org/changeset/base/342747

zfsboot: support newer ZFS versions
declare v3 objset size/layout to fix userboot and possibly other loader issues

    - fix for userboot assertion failure in zfs_dev_close in free due to out of bounds write
    - fix for zfs_alloc / zfs_free mismatch assertion failure when booting GPT on BIOS

And yes, thats from ZoL.

History

#1 Updated by Electric Monk about 1 month ago

  • % Done changed from 90 to 100
  • Status changed from In Progress to Closed

git commit 08487eea68a2fa501b5042131c6db068089f82e1

commit  08487eea68a2fa501b5042131c6db068089f82e1
Author: Toomas Soome <tsoome@me.com>
Date:   2019-01-14T16:06:06.000Z

    10173 loader: support newer ZFS versions
    Reviewed by: Andy Fiddaman <af@citrus-it.net>
    Reviewed by: Gergő Mihály Doma <domag02@gmail.com>
    Reviewed by: Jason King <jbk@joyent.com>
    Approved by: Dan McDonald <danmcd@joyent.com>

Also available in: Atom