Project

General

Profile

Bug #1025

GRUB loading failure

Added by Artem D over 8 years ago. Updated over 8 years ago.

Status:
Closed
Priority:
Normal
Assignee:
Category:
OS/Net (Kernel and Userland)
Target version:
Start date:
2011-05-12
Due date:
2011-09-14
% Done:

0%

Estimated time:
40.00 h
Difficulty:
Medium
Tags:
grub

Description

System Configuration: Gigabyte Technology Co., Ltd. GA-790XT-USB3
BIOS Configuration: Award Software International, Inc. F5a 09/23/2010

==== Processor Sockets ====================================

Version Location Tag
-------------------------------- --------------------------
AMD Athlon(tm) II X4 615e Processor Socket M2

==== Memory Device Sockets ================================

Type Status Set Device Locator Bank Locator
----------- ------ --- ------------------- ----------------
unknown in use 0 A0 Bank0/1
unknown in use 0 A1 Bank2/3
unknown in use 0 A2 Bank4/5
unknown in use 0 A3 Bank6/7

==== On-Board Devices =====================================

==== Upgradeable Slots ====================================

ID Status Type Description
--- --------- ---------------- ----------------------------
7 available PCI PCI
6 available PCI PCI
8 available PCI PCI
0 unknown PCI Express PCI Express x16
0 unknown PCI Express PCI Express x16
0 unknown PCI Express PCI Express x1
0 unknown PCI Express PCI Express x1

prtconf: see file attached

cfgadm -al
Ap_Id Type Receptacle Occupant Condition
sata0/0 sata-port empty unconfigured ok
sata0/1 sata-port empty unconfigured ok
sata0/2 sata-port empty unconfigured ok
sata0/3 sata-port empty unconfigured ok
sata0/4::dsk/c1t4d0 disk connected configured ok
sata0/5 sata-port empty unconfigured ok
sata1/0::dsk/c3t0d0 disk connected configured ok
sata1/1::dsk/c3t1d0 disk connected configured ok
sata2/0::dsk/c4t0d0 disk connected configured ok
sata2/1::dsk/c4t1d0 disk connected configured ok

Boot disk:
sata0/4::dsk/c1t4d0

RAIDZ disks:
sata1/0::dsk/c3t0d0 disk connected configured ok
sata1/1::dsk/c3t1d0 disk connected configured ok
sata2/0::dsk/c4t0d0 disk connected configured ok
sata2/1::dsk/c4t1d0 disk connected configured ok

Boot disk is connected to the motherboard.
4 Raid-z disks are connected to 2 SATA cards (si3124) in pci-e slots:
PCIEX1_1 (channel 0 and channel 1) and PCIEX1_2 (channel 0 and channel 1)

BIOS initializes PCIEX1_1 then PCIEX1_2 first, and on-board SATA last.
There is no way to change the order.

In BIOS disks are recognized as:
boot disk - SCSI-4

raidz disks - SCSI-0, SCSI-1, SCSI-2, SCSI-3

When raidz disks are inserted, GRUB stage2 load fails.

Loading operating system...
GRUB Loading stage2...

and that's all.

All possible combinations:
1. PCIEX1_1 ch 0 & ch 1 occupied
PCIEX1_2 ch 0 & ch 1 empty
Result: Boot succeed.

2. PCIEX1_1 ch 0 & ch 1 empty
PCIEX1_2 ch 0 & ch 1 occupied
Result: Boot succeed.

3. PCIEX1_1 ch 0 occupied, ch 1 empty
PCIEX1_2 ch 0 occupied, ch 1 empty
Result: GRUB stage2 load failure

4. PCIEX1_1 ch 0 empty, ch 1 occupied
PCIEX1_1 ch 0 empty, ch 1 occupied
Result: GRUB stage2 load failure

5. PCIEX1_1 ch 0 empty, ch 1 occupied
PCIEX1_1 ch 0 occupied, ch 1 empty
Result: GRUB load failure
Console output: Loading Operating System...
GRUB Loading stage2...
GRUB GRUB
6. PCIEX1_1 ch 0 occupied, ch 1 empty
PCIEX1_1 ch 0 empty, ch 1 occupied
Result: GRUB load failure
Console output: Loading Operating System...
GRUB Loading stage2...
GRUB

Boot order is set properly in BIOS


Files

prtconf-v.out (229 KB) prtconf-v.out Artem D, 2011-05-12 01:07 PM
Screen_shot_2011-06-09_at_1.18.55_PM.png (15.5 KB) Screen_shot_2011-06-09_at_1.18.55_PM.png Artem D, 2011-06-09 10:23 AM

History

#1

Updated by Julian Wiesener over 8 years ago

  • Status changed from New to Feedback
  • Assignee set to Julian Wiesener
  • Priority changed from High to Normal
  • Tags changed from needs-triage to grub

Sorry i don't see a Bug here. If you change the disk order for the boot disk (by inserting disk to the prefered off-board controller) grub will not longer find it's stage2. You need to make sure that either the additional disks appear after the onboard disks (possible BIOS/Controller config) or, write rewrite grub with the disks are inserted.

#2

Updated by Artem D over 8 years ago

The problem is, that you are only partially right.
BIOS/Controller init sequence config is not always available (right in my case).
And, rewriting grub does not help.
Even if I try to reinstall the OS with_all_disks_inserted (in this case, boot disk appears
as /dev/dsk/c3t4d0 both during the install and during the booting) - the result is the same.
I see:
GRUB Loading stage2...
GRUB

End of story.
Looks like GRUB could not load from non-first device - this is a bug.

#3

Updated by Artem D over 8 years ago

What is more, the same behavior is when I use Solaris 11.
I tried to use openindiana in hope that it doesn't behave such a way - no luck.

#4

Updated by Julian Wiesener over 8 years ago

Have you tried to install grub manually from live dvd with alldisks attached?

/a/usr/sbin/installgrub -m /a/boot/grub/stage1 /a/boot/grub/stage2 /dev/rdsk/c1t4d0s0

#5

Updated by Julian Wiesener over 8 years ago

i recently did a test, changing the bootdevice from the first to the second disk, wasn't a problem. seems to be more hardware specific, need someone with more similar hardware to dig that down

#6

Updated by Artem D over 8 years ago

Have you tried to install grub manually from live dvd with alldisks attached?
/a/usr/sbin/installgrub -m /a/boot/grub/stage1 /a/boot/grub/stage2 /dev/rdsk/c1t4d0s0

I did the similar, but from the installer: installed from the beginning OS, chose 5-th disk (as disks from 1 to 4 are used in ZFS raid), reboot - no luck. To boot OS successfully, I have to remove all disks connected to one of sata cards (e.g. left only 2 from ZFS RAID).
Maybe, GRUB can not boot from disk higher than 3-rd ? Or interfere with ZFS on first 4 disks ?

#7

Updated by Artem D over 8 years ago

I recently did a test, changing the bootdevice from the first to the second disk, wasn't a
problem. seems to be more hardware specific, need someone with more similar hardware to dig that down

Well, if you need some specific actions and tests - no problem, I could provide you everything you need (I'm a Sun field engineer :-)

#8

Updated by Artem D over 8 years ago

Looks like the same problem is reproducible in VirtualBox

Steps to reproduce:
1. Create VM with 2 sata disks (channel 0 & channel 1)
2. Run IndianaOS installer, install OS on disk connected to channel 1. Leave disk on channel 0 untouched.
3. After the install, power off & power on VM. Press F12 to choose boot device. Select "AHCI Controller" - > 2. Secondary Slave
4. Got "GRUB" message (see screenshot attached)

#9

Updated by Julian Wiesener over 8 years ago

  • Assignee deleted (Julian Wiesener)

Well, i found noone who want to work on that bug and i will also not for the moment. Needs someone who breake it down to actuall causes before it can get to oi_illumos. Testers need to make sure that on Disk/Files they are booting from, are no bits from previous grub installations ans will be required to boot from a >=third disk.

#10

Updated by Ken Mays over 8 years ago

  • Due date set to 2011-09-14
  • Category set to OS/Net (Kernel and Userland)
  • Status changed from Feedback to Closed
  • Assignee set to OI illumos
  • Target version set to oi_151_stable
  • Estimated time set to 40.00 h

Please refile this bug in the Illumos_gate bug tracker. This issue not handled by the OI-dev team.

Also available in: Atom PDF