Bug #1039

/usr/lib/smbsrv/smbd prevents suspend

Added by Gordon Ross almost 3 years ago. Updated almost 3 years ago.

Status:Resolved Start date:2011-05-16
Priority:Normal Due date:
Assignee:Gordon Ross % Done:

0%

Category:- Spent time: -
Target version:-
Difficulty:Medium Tags:needs-triage

Description

From this discussion:
http://openindiana.org/pipermail/openindiana-discuss/2011-May/003820.html

One gets this error when trying to suspend:

May 15 05:05:25 fileserv genunix: [ID 535284 kern.notice] System is being suspended May 15 05:05:55 fileserv genunix: [ID 520228 kern.warning] WARNING: Suspend cannot stop process /usr/lib/smbsrv/smbd start (ffffff026f8e00c0:1). May 15 05:05:55 fileserv genunix: [ID 903701 kern.warning] WARNING: Process may be waiting for network request, please try again. May 15 05:05:57 fileserv genunix: [ID 583038 kern.notice] System has been resumed.

This is a known bug from Solaris 11 Express that was fixed in build 156. It's pretty easy to get around this temporarily by disabling smb

History

Updated by Gordon Ross almost 3 years ago

  • Status changed from New to In Progress
  • Assignee set to Gordon Ross

The problem is that the smb_server_spooldoc thread is blocked in
cv_wait and cannot be killed. (This also interferes with suspend.)

Change it to use cv_wait_sig and return EINTR.
Also EAGAIN for possible false wakeups.

http://www.yalms.org/cr/illumos-1039/

Updated by Gordon Ross almost 3 years ago

  • Status changed from In Progress to Resolved

changeset: 13378:d6c0163a1c2e
tag: tip
user: Gordon Ross <>
date: Fri May 27 22:06:40 2011 -0400
description:
1039 /usr/lib/smbsrv/smbd prevents suspend
Reviewed by: Eric Schrock <>
Reviewed by: Richard Lowe <>
Approved by: Garrett D'Amore <>

Also available in: Atom PDF