Project

General

Profile

Bug #1048

getpass.getpass python function doesn't hide input

Added by Tim Sarbin almost 10 years ago. Updated over 8 years ago.

Status:
Closed
Priority:
Normal
Assignee:
Category:
Desktop (JDS)
Target version:
Start date:
2011-05-19
Due date:
2011-09-16
% Done:

80%

Estimated time:
1.00 h
Difficulty:
Medium
Tags:
python

Description

The following code should print "Password: " on the command line, then get user text input without displaying it on the screen.

import getpass
passStr = getpass.getpass("Password: ")

It does hide input initially, but on pressing Enter, it then writes the entire password to the screen. (Expected output is nothing at all).

#1

Updated by Ryo Murakawa almost 10 years ago

  • Tags changed from needs-triage to python
#2

Updated by Ryo Murakawa almost 10 years ago

  • Assignee set to Ryo Murakawa
#3

Updated by Ryo Murakawa almost 10 years ago

  • Assignee changed from Ryo Murakawa to OI PKG
#4

Updated by Julian Wiesener almost 10 years ago

  • Target version changed from oi_151 to oi_151_stable
#5

Updated by Ken Mays over 9 years ago

  • Due date set to 2011-09-16
  • Category set to 10
  • Status changed from New to Resolved
  • Assignee changed from OI PKG to Ken Mays
  • % Done changed from 0 to 100
  • Estimated time set to 1.00 h
#6

Updated by Albert Lee over 9 years ago

  • Category changed from 10 to Desktop (JDS)
  • Status changed from Resolved to Feedback
  • Assignee changed from Ken Mays to OI JDS
  • % Done changed from 100 to 80

Ken Mays wrote:

Tim - please use the runtime/python-32 package in our SFE repo for serious Python development.

That is utterly wrong.

However, I cannot reproduce this problem in oi_151a, using gnome-terminal with TERM=xterm or TERM=xterm-color and tmux with TERM=screen. This could have been resolved in a terminfo update. Please test this on oi_151a.

#7

Updated by Jon Tibble over 8 years ago

  • Status changed from Feedback to Closed

Closing as unable to replicate (works as per the described expectation on oi_151a5) and no feedback forthcoming.

Also available in: Atom PDF