Project

General

Profile

Bug #10513

Regression in westmere MCA initialization

Added by Robert Mustacchi about 1 month ago. Updated about 1 month ago.

Status:
Closed
Priority:
Normal
Category:
kernel
Start date:
2019-03-08
Due date:
% Done:

100%

Estimated time:
Difficulty:
Medium
Tags:

Description

Booting on a Westmere system, I was greeted with error messages about MCA support. I suspect this is a regression introduced by 10277. The problem is that the APIC ID space isn't uniform, which the changes were somewhat relying on. Instead we need to use the number of required bits to cover the space as was previously used.

History

#1

Updated by Electric Monk about 1 month ago

  • Status changed from New to Closed

git commit d6517bbd3d5d20a36c32ac87627207632e5934aa

commit  d6517bbd3d5d20a36c32ac87627207632e5934aa
Author: Robert Mustacchi <rm@joyent.com>
Date:   2019-03-12T15:31:31.000Z

    10514 10277 broke older Intel CPUs
    10513 Regression in westmere MCA initialization
    Reviewed by: Jerry Jelinek <jerry.jelinek@joyent.com>
    Reviewed by: John Levon <john.levon@joyent.com>
    Reviewed by: Peter Tribble <peter.tribble@gmail.com>
    Approved by: Dan McDonald <danmcd@joyent.com>

Also available in: Atom PDF