Project

General

Profile

Actions

Bug #10514

closed

10277 broke older Intel CPUs

Added by Robert Mustacchi over 3 years ago. Updated over 3 years ago.

Status:
Closed
Priority:
Normal
Category:
kernel
Start date:
2019-03-08
Due date:
% Done:

100%

Estimated time:
Difficulty:
Medium
Tags:
Gerrit CR:

Description

The changes in 10277 were not quite correct and on older Intel CPUs without CPUID leaf 0xb, such systems fail to boot. The problem is that the logic in cpuid_intel_ncores() is incorrect. While we correctly source the number of cores via leaf 4, we incorrectly assigned the number of threads based on the number sharing the smallest cache. This is basically never correct.

Instead, this needs to be obtained the same way it was in the past, via cpuid leaf 1.


Related issues

Related to illumos gate - Feature #10277: Properly detect SMT on AMDClosed2019-01-24

Actions
Actions

Also available in: Atom PDF