Bug #10523


Boot freeze

Added by Cristian Achim over 3 years ago. Updated over 3 years ago.

Target version:
Start date:
Due date:
% Done:


Estimated time:


I have a 2018.04 OI live-DVD from which I tried to install. The default boot process
doesn't do updates to the screen just after 'Copyright Oracle'. The DVD is spinning
for some more time after that though.

My system is an ASUS K31CD with Core i3 and American Megathrends BIOS.

I tried booting with legacy ACPI, vesa driver, text console and still failure to boot.

Following some debug documentation on kmdb I selected debug, kmdb and verbose
from the boot menu and received following results that may or may not be relevant:

> kmdb stuff
loaded modules: [unix krtld genunix]
moddebug/W 80000000
snooping/W 1
...loads of stuff printed to screen.......
load 'fs/sharefs' id56 loaded at f...f79ee000
0xf...fbe96017 size 7024/384
installing sharefs, module id 56.
>freeze here

I also have results for ::stack ::status ::msgbuf, but they are all from where the
boot process entered kmdb mode and not close in time to the freeze. Mabe if I
could make kmdb halt the boot process right where the loading of sharefs above
starts and then do some debugging? I am willing but I would like someone to
guide me along.

I also have a OI live-USB of 2018.10 but it is detected by the BIOS as 'UEFI-USB-...'
and the BIOS searches for a UEFI boot partition and since there is none it errors out.

Actions #1

Updated by Michal Nowak over 3 years ago

Thanks for the report, Cristian. There are few things you can try to help to debug this.

Start with the latest OI DVD snapshot, that is 2018.10 (or was that a typo?).

If ACPI is the problem, set it to off.

There are ways to trigger kmdb on hang, see (though note that this mostly works for server-class HW).

If boot from USB does not work due to UEFI, maybe you can force BIOS in the Setup Utility?

Actions #2

Updated by Cristian Achim over 3 years ago

I disabled ACPI on the live-DVD boot menu and the 2018.04 system completed the
loading of the OS. After that I installed it on disk. From the disk it didn't boot with
ACPI either, but disabling ACPI I could boot from disk and update the system.
After the update it boots fine without messing around with boot options.

Actions #3

Updated by Cristian Achim over 3 years ago

PS - the bugtracker sign out button is broken for me. It gives 404 and some nginx


Also available in: Atom PDF