Project

General

Profile

Bug #1055

Root user password + GUI tools problem

Added by Tim Sarbin over 8 years ago. Updated almost 7 years ago.

Status:
Closed
Priority:
Normal
Assignee:
-
Category:
Desktop (JDS)
Target version:
-
Start date:
2011-05-20
Due date:
% Done:

100%

Estimated time:
Difficulty:
Medium
Tags:
needs-triage

Description

On a fresh install of OI, the root password is expired and requires changing before commands like sudo can be ran. This is fine on the terminal as it simply asks for a new password (the current being whatever the user specified during install). However, a more typical scenario is that the user will try to run a program in the GUI that requires admin privs, and it will ask for admin password, but will always fail due to password expiry. If you go to the console and update the root password, the gui stuff works as expected. Either password for root needs to not expire (unlikely), or we need to check for expiry and pop up a nice dialog asking to update before continuing (more likely).


Related issues

Is duplicate of OpenIndiana Distribution - Bug #636: Fix graphical installer to prevent root password expiringClosed2011-01-16

Actions

History

#1

Updated by Andrew Stormont over 8 years ago

sudo works fine. pfexec is the problem

#2

Updated by Guido Berhörster over 8 years ago

Either password for root needs to not expire (unlikely), or we need to check for expiry and pop up a nice dialog asking to update before continuing (more likely).

The former is the proposed solution for oi_151, later builds should have fixes from Oracle to deal with expired passwords more gracefully.

#3

Updated by Alasdair Lumsden over 8 years ago

  • Target version changed from oi_151 to oi_151_stable
#4

Updated by Ken Mays almost 7 years ago

  • Status changed from New to Closed
  • Assignee deleted (Guido Berhörster)
  • Target version deleted (oi_151_stable)
  • % Done changed from 0 to 100

Resolved in using JDS updates from pkg.opensolaris.cz:10000.

Also available in: Atom PDF