Project

General

Profile

Actions

Feature #10578

closed

implement fmemopen(3C)

Added by Joshua M. Clulow over 2 years ago. Updated about 1 year ago.

Status:
Duplicate
Priority:
Normal
Category:
lib - userland libraries
Start date:
2019-03-21
Due date:
% Done:

0%

Estimated time:
Difficulty:
Medium
Tags:
Gerrit CR:

Description

It would help to have an implementation of fmemopen(). This routine is described in POSIX and, perhaps more importantly, is available in glibc and all of the BSDs. Of particular note, Samba 4.10.0 has come to depend on this function.

When implementing this function, it may be worth considering an implementation that would get us the funopen suite of functions that the BSDs provide as well.

Note that at least in gnulib, a terrible, horrible, no good thing has been done: a local definition of what should have been an opaque structure has been included in lib/stdio-impl.h -- we'll need to be careful that any changes to our stdio implementation don't move these members around or change their meaning.


Related issues

Is duplicate of illumos gate - Feature #7092: Want support for stdio memory streamsClosedRobert Mustacchi

Actions
Actions #1

Updated by Joshua M. Clulow over 2 years ago

  • Tracker changed from Bug to Feature
Actions #2

Updated by Joshua M. Clulow over 2 years ago

  • Description updated (diff)
Actions #3

Updated by Joshua M. Clulow over 2 years ago

  • Description updated (diff)
Actions #4

Updated by Robert Mustacchi over 1 year ago

  • Is duplicate of Feature #7092: Want support for stdio memory streams added
Actions #5

Updated by Robert Mustacchi over 1 year ago

  • Status changed from New to Closed
  • Assignee set to Robert Mustacchi

See 7092 for this.

Actions #6

Updated by Joshua M. Clulow about 1 year ago

  • Status changed from Closed to Duplicate
Actions

Also available in: Atom PDF