Project

General

Profile

Actions

Feature #10695

closed

import zlib-1.2.11

Added by Toomas Soome about 3 years ago. Updated about 3 years ago.

Status:
Closed
Priority:
Normal
Assignee:
Category:
system data
Start date:
2019-04-06
Due date:
% Done:

100%

Estimated time:
Difficulty:
Medium
Tags:
needs-triage
Gerrit CR:

Description

We have 3 instances of zlib sources in our tree, lets add one more.

spppcomp has zlib-1.1.3.
zmod has 1.2.3
loader has 1.2.8

and current version is 1.2.11 from 2017 - therefore it should be sufficiently tested to be used in illumos.

add sources to usr/src/contrib/zlib, so the followups could use them and purge old versions. The master and illumos diff will appear in github in separate repo as it is done with mdns. github url is: https://github.com/illumos/zlib

zlib-1.2.11 is already tested with loader and zfs (zmod).


Related issues

Related to illumos gate - Bug #10697: zmod: use zlib-1.2.11ClosedToomas Soome2019-04-06

Actions
Related to illumos gate - Bug #14626: zlib: update to zlib-1.2.12ClosedToomas Soome

Actions
Related to illumos gate - Bug #10696: loader: use zlib-1.2.11ClosedToomas Soome2019-04-06

Actions
Actions #1

Updated by Toomas Soome about 3 years ago

  • Description updated (diff)
Actions #2

Updated by Electric Monk about 3 years ago

  • Status changed from In Progress to Closed
  • % Done changed from 90 to 100

git commit b83829353d4a26013e3ab27abdaadbf8ea060738

commit  b83829353d4a26013e3ab27abdaadbf8ea060738
Author: Toomas Soome <tsoome@me.com>
Date:   2019-04-21T15:29:44.000Z

    10695 import zlib-1.2.11
    Reviewed by: Gergő Doma <domag02@gmail.com>
    Reviewed by: Andy Fiddaman <andy@omniosce.org>
    Approved by: Richard Lowe <richlowe@richlowe.net>

Actions #3

Updated by Marcel Telka about 2 months ago

  • Related to Bug #10697: zmod: use zlib-1.2.11 added
Actions #4

Updated by Marcel Telka about 2 months ago

  • Related to Bug #14626: zlib: update to zlib-1.2.12 added
Actions #5

Updated by Marcel Telka about 2 months ago

  • Related to Bug #10696: loader: use zlib-1.2.11 added
Actions

Also available in: Atom PDF