Project

General

Profile

Feature #1088

smbclient devlink.tab and devfsadm cleanup

Added by Gordon Ross over 8 years ago. Updated over 8 years ago.

Status:
Resolved
Priority:
Normal
Assignee:
Category:
-
Start date:
2011-06-01
Due date:
% Done:

0%

Estimated time:
Difficulty:
Bite-size
Tags:
needs-triage

Description

While fixing another issue:
1075 smbsrv missing /dev/* link
it was discovered that the SMB client has both a
devlink.tab and devfsadm entry for creating its
/dev/* link. It should only have devfsadm.

(Making this cleanup a "feature" because there's
no observable defect caused by this.)

History

#1

Updated by Gordon Ross over 8 years ago

  • Status changed from New to Resolved

changeset: 13383:47508b8cd2eb
tag: tip
user: Gordon Ross <>
date: Fri Jun 03 11:40:03 2011 -0400

description:
1075 smbsrv missing /dev/* link
1076 smbsrv install and packaging cleanup
1088 smbclient devlink.tab and devfsadm cleanup
Reviewed by: Garrett D'Amore <>
Reviewed by: Eric Schrock <>
Reviewed by: Dan McDonald <>
Approved by: Garrett D'Amore <>

modified:
exception_lists/packaging
usr/src/cmd/devfsadm/misc_link.c
usr/src/cmd/mdb/intel/amd64/smbsrv/Makefile
usr/src/cmd/mdb/intel/ia32/smbsrv/Makefile
usr/src/cmd/mdb/sparc/v9/smbsrv/Makefile
usr/src/cmd/smbsrv/smbd/smbd_main.c
usr/src/lib/smbsrv/libsmb/common/smb_kmod.c
usr/src/pkg/manifests/service-file-system-smb.mf
usr/src/pkg/manifests/system-file-system-smb.mf
usr/src/uts/intel/smbsrv/Makefile
usr/src/uts/sparc/smbsrv/Makefile

Also available in: Atom PDF