Project

General

Profile

Bug #10892

AVX-512 dis tests fail with 'Error: zeroing-masking only allowed with write mask'

Added by Robert Mustacchi 7 months ago. Updated 6 months ago.

Status:
Closed
Priority:
Normal
Category:
tests
Start date:
2019-05-01
Due date:
% Done:

100%

Estimated time:
Difficulty:
Medium
Tags:

Description

The AVX-512 dis tests fail against a newer version of gas. The problem is that they don't properly assemble. In particular we see something like:

...
32.avx512.s: Assembler messages:
32.avx512.s:47: Error: zeroing-masking only allowed with write mask
32.avx512.s:56: Error: zeroing-masking only allowed with write mask
32.avx512.s:101: Error: zeroing-masking only allowed with write mask
32.avx512.s:102: Error: zeroing-masking only allowed with write mask
32.avx512.s:103: Error: zeroing-masking only allowed with write mask
32.avx512.s:104: Error: zeroing-masking only allowed with write mask
32.avx512.s:105: Error: zeroing-masking only allowed with write mask
32.avx512.s:106: Error: zeroing-masking only allowed with write mask
32.avx512.s:111: Error: zeroing-masking only allowed with write mask
32.avx512.s:112: Error: zeroing-masking only allowed with write mask
32.avx512.s:113: Error: zeroing-masking only allowed with write mask
32.avx512.s:114: Error: zeroing-masking only allowed with write mask
32.avx512.s:115: Error: zeroing-masking only allowed with write mask
32.avx512.s:116: Error: zeroing-masking only allowed with write mask
32.avx512.s:121: Error: zeroing-masking only allowed with write mask
32.avx512.s:122: Error: zeroing-masking only allowed with write mask
32.avx512.s:123: Error: zeroing-masking only allowed with write mask
32.avx512.s:124: Error: zeroing-masking only allowed with write mask
32.avx512.s:125: Error: zeroing-masking only allowed with write mask
32.avx512.s:126: Error: zeroing-masking only allowed with write mask
32.avx512.s:131: Error: zeroing-masking only allowed with write mask
32.avx512.s:132: Error: zeroing-masking only allowed with write mask
32.avx512.s:133: Error: zeroing-masking only allowed with write mask
32.avx512.s:134: Error: zeroing-masking only allowed with write mask
...

The problem is that we have zero masking extensions illegally placed with out the register masks. The fix is to have the tests have these kinds of masks.

I tested this by running the full dis test suite with gas 2.26.1 and 2.30. 2.30 was the version that complained. Now it passed without issue.

History

#1

Updated by Electric Monk 6 months ago

  • Status changed from New to Closed

git commit e4f9a3693d33f81a9a8d8484016c2a2434f4e59b

commit  e4f9a3693d33f81a9a8d8484016c2a2434f4e59b
Author: Robert Mustacchi <rm@joyent.com>
Date:   2019-05-05T15:35:10.000Z

    10892 AVX-512 dis tests fail with 'Error: zeroing-masking only allowed with write mask'
    Reviewed by: Patrick Mooney <patrick.mooney@joyent.com>
    Reviewed by: Jerry Jelinek <jerry.jelinek@joyent.com>
    Approved by: Gordon Ross <gwr@nexenta.com>

Also available in: Atom PDF