Project

General

Profile

Bug #1090

net-snmp shouldn't define HAVE_CPP_UNDERBAR_FUNCTION_DEFINED

Added by Yuri Pankov almost 9 years ago. Updated almost 9 years ago.

Status:
Closed
Priority:
Normal
Assignee:
-
Category:
-
Target version:
-
Start date:
2011-06-03
Due date:
% Done:

0%

Estimated time:
Difficulty:
Medium
Tags:
needs-triage

Description

system/management/snmp/net-snmp shouldn't have HAVE_CPP_UNDERBAR_FUNCTION_DEFINED defined in net-snmp/net-snmp-config.h as it breaks the Illumos build:

[...]
+ /opt/SUNWspro/bin/cc -O -K pic -xspace -Xa -xildoff -errtags=yes -errwarn=%all -erroff=E_EMPTY_TRANSLATION_UNIT -erroff=E_STATEMENT_NOT_REACHED -xc99=%none -W0,-xglobalstatic -v -K PIC -g -x
c99=%none -W0,-noglobal -xdebugformat=stabs -DTEXT_DOMAIN="SUNW_OST_OSLIB" -D_TS_ERRNO -I/home/yuri/ws/illumos/proto/root_i386/usr/include -I../common -I. -DDEBUG -DPIC -D_REENTRANT -c -o pics
/init.o ../common/init.c
"../common/init.c", line 61: undefined symbol: __FUNCTION__
cc: acomp failed for ../common/init.c
*** Error code 2
dmake: Fatal error: Command failed for target `pics/init.o'
Current working directory /home/yuri/ws/illumos/usr/src/lib/fm/libfmd_snmp/i386
[...]

History

#1

Updated by Yuri Pankov almost 9 years ago

That's with:

$ pkg list net-snmp
NAME (PUBLISHER)                              VERSION         STATE      UFOXI
system/management/snmp/net-snmp               5.4.1-0.151     installed  -----

Previous versions (probably) didn't have this problem.

#2

Updated by Chris Jordan almost 9 years ago

  • Status changed from New to Closed

This is a duplicate of bug #1078, so I am closing it.

Also available in: Atom PDF