Project

General

Profile

Bug #10908

Simplify SMAP relocations with krtld

Added by John Levon over 1 year ago. Updated over 1 year ago.

Status:
Closed
Priority:
Normal
Assignee:
Category:
-
Start date:
2019-05-03
Due date:
% Done:

0%

Estimated time:
Difficulty:
Medium
Tags:
needs-triage
Gerrit CR:

History

#1

Updated by John Levon over 1 year ago

Today, SMAP is enabled and disabled by making a function call to smap_enable and smap_disable at the appropriate times. It would be cleaner, and faster, to simply arrange for the appropriate instructions to appear in place of those calls. We can achieve this in krtld by adjusting the program text in a similar fashion to that used for DTrace SDT probe sites.

#2

Updated by John Levon over 1 year ago

  • Status changed from New to Closed

Dupe of #9059

Also available in: Atom PDF