Project

General

Profile

Bug #10971

SMB2 kstats don't correctly count compound requests

Added by Gordon Ross 5 months ago. Updated 5 months ago.

Status:
Closed
Priority:
Normal
Assignee:
Category:
-
Start date:
2019-05-14
Due date:
% Done:

100%

Estimated time:
Difficulty:
Medium
Tags:
needs-triage

Description

Running smbstat -r, there are time when % inexplicably doesn't add up to 100.

Steps to Reproduce:

smbstat -rz 10

Expected Results:

% always add up to 100.

History

#1

Updated by Gordon Ross 5 months ago

  • Description updated (diff)
  • Status changed from New to In Progress
#2

Updated by Gordon Ross 5 months ago

The main problem is 'overcount' (exclusive to SMB2+). It happens because the 'total number of requests' is only increased when a message is received, but the 'individual number of requests' is incremented for each request in a compound. This means the sum of individual request counts can exceed the total number of requests counted. Move the increments so these reconcile.

#3

Updated by Electric Monk 5 months ago

  • Status changed from In Progress to Closed
  • % Done changed from 0 to 100

git commit ac2bf314e776a9dcb4faf4d3f88408ed942f0fae

commit  ac2bf314e776a9dcb4faf4d3f88408ed942f0fae
Author: Matt Barden <matt.barden@nexenta.com>
Date:   2019-05-19T23:21:45.000Z

    10971 SMB2 kstats don't correctly count compound requests
    Reviewed by: Gordon Ross <gordon.ross@nexenta.com>
    Reviewed by: Evan Layton <evan.layton@nexenta.com>
    Approved by: Joshua M. Clulow <josh@sysmgr.org>

Also available in: Atom PDF