Project

General

Profile

Bug #10972

SMB1 tree connect missing some features

Added by Gordon Ross 8 days ago. Updated 2 days ago.

Status:
Closed
Priority:
Normal
Assignee:
Category:
-
Start date:
2019-05-14
Due date:
% Done:

100%

Estimated time:
Difficulty:
Medium
Tags:
needs-triage

Description

Recent versions of the [MS-SMB] specification from Microsoft define some additional flags for SMB1 tree connect:
TREE_CONNECT_ANDX_EXTENDED_RESPONSE
TREE_CONNECT_ANDX_DISCONNECT_TID

Without these, some clients may not talk to us.
One client found to fail is smbtorture from Samba4.

Steps to Reproduce:
smbtorture ... raw.notify

Expected Results:
Should (mostly*) work.
( \* there are some notify "failures" that we consider test bugs. )

Actual Results:
Tree connect fails.

History

#1

Updated by Gordon Ross 5 days ago

  • Description updated (diff)
  • Status changed from New to In Progress
#2

Updated by Gordon Ross 5 days ago

Testing: smbtorture raw.notify
In production since late 2015

#3

Updated by Electric Monk 2 days ago

  • Status changed from In Progress to Closed
  • % Done changed from 0 to 100

git commit 593e4726be8e43f7def1376a7c6b9fb2f448d01e

commit  593e4726be8e43f7def1376a7c6b9fb2f448d01e
Author: Gordon Ross <gwr@nexenta.com>
Date:   2019-05-21T12:07:54.000Z

    10972 SMB1 tree connect missing some features
    Reviewed by: Bayard Bell <bayard.bell@nexenta.com>
    Reviewed by: Kevin Crowe <kevin.crowe@nexenta.com>
    Reviewed by: Matt Barden <matt.barden@nexenta.com>
    Reviewed by: Evan Layton <evan.layton@nexenta.com>
    Approved by: Dan McDonald <danmcd@joyent.com>

Also available in: Atom PDF