Project

General

Profile

Feature #10974

SMB1 create file should support extended_response format

Added by Gordon Ross 5 months ago. Updated 5 months ago.

Status:
Closed
Priority:
Normal
Assignee:
Category:
-
Start date:
2019-05-14
Due date:
% Done:

100%

Estimated time:
Difficulty:
Medium
Tags:
needs-triage

Description

The [MS-SMB] specification introduced some modifications to the "create" calls: SMB_NT_CREATE, NT_TRANS_CREATE, etc. that we don't implement. Some clients (and many tests) expect these.

Note: #10972 is a similar MS-SMB extension, in that case affecting tree_connect.

Steps to Reproduce:
run smbtorture raw.open, particularly:
raw.open.openx.openx
raw.open.ntcreatex.ntcreatex

Expected Results:
pass

Actual Results:
failure

History

#1

Updated by Gordon Ross 5 months ago

  • Tracker changed from Bug to Feature
#2

Updated by Gordon Ross 5 months ago

  • Description updated (diff)
  • Status changed from New to In Progress
#3

Updated by Gordon Ross 5 months ago

  • Description updated (diff)
#4

Updated by Gordon Ross 5 months ago

  • Description updated (diff)
#5

Updated by Gordon Ross 5 months ago

Tested per the description.
In production since early 2016

#6

Updated by Electric Monk 5 months ago

  • Status changed from In Progress to Closed
  • % Done changed from 0 to 100

git commit c5f48fa536d16d8fe59d1bb62faa7eb8e891610c

commit  c5f48fa536d16d8fe59d1bb62faa7eb8e891610c
Author: Gordon Ross <gwr@nexenta.com>
Date:   2019-05-21T12:07:55.000Z

    10974 SMB1 create file should support extended_response format
    Reviewed by: Matt Barden <Matt.Barden@nexenta.com>
    Reviewed by: Bayard Bell <bayard.bell@nexenta.com>
    Reviewed by: Alek Pinchuk <alek.pinchuk@nexenta.com>
    Reviewed by: Rick McNeal <rick.mcneal@nexenta.com>
    Reviewed by: Kevin Crowe <kevin.crowe@nexenta.com>
    Reviewed by: Evan Layton <evan.layton@nexenta.com>
    Approved by: Dan McDonald <danmcd@joyent.com>

Also available in: Atom PDF