Project

General

Profile

Feature #10980

Should pass the smbtorture lock tests

Added by Gordon Ross 5 months ago. Updated 5 months ago.

Status:
Closed
Priority:
Normal
Assignee:
Category:
-
Start date:
2019-05-14
Due date:
% Done:

100%

Estimated time:
Difficulty:
Medium
Tags:
needs-triage

Description

We currently fail many of the smbtorture lock tests.
Most of those should pass.

Steps to Reproduce:
smbtorture -U smb%nexenta //server/share raw.lock
smbtorture -U smb%nexenta //server/share smb2.lock

Expected Results:
mostly pass

Actual Results:
mostly fail

History

#1

Updated by Gordon Ross 5 months ago

  • Description updated (diff)
  • Status changed from New to In Progress
#2

Updated by Gordon Ross 5 months ago

Fix involved some redesign in the common smb_lock.c code.
Testing: as in the description
Fix in production since late 2016

#3

Updated by Electric Monk 5 months ago

  • Status changed from In Progress to Closed
  • % Done changed from 0 to 100

git commit 0897f7fbb62326e60e858c62a1654b2ca3e2667e

commit  0897f7fbb62326e60e858c62a1654b2ca3e2667e
Author: Gordon Ross <gwr@nexenta.com>
Date:   2019-05-23T02:59:03.000Z

    10980 Should pass the smbtorture lock tests
    Portions contributed by: Matt Barden <matt.barden@nexenta.com>
    Reviewed by: Kevin Crowe <kevin.crowe@nexenta.com>
    Reviewed by: Evan Layton <evan.layton@nexenta.com>
    Reviewed by: Yuri Pankov <yuri.pankov@nexenta.com>
    Approved by: Dan McDonald <danmcd@joyent.com>

Also available in: Atom PDF