Project

General

Profile

Bug #10988

SMB should not create in directories marked delete-on-close

Added by Gordon Ross 5 months ago. Updated 5 months ago.

Status:
Closed
Priority:
Normal
Assignee:
Category:
-
Start date:
2019-05-14
Due date:
% Done:

100%

Estimated time:
Difficulty:
Medium
Tags:
needs-triage

Description

The SMB server allows creating files in a directory marked "delete-on-close"
where it should return STATUS_DELETE_PENDING.

Steps to Reproduce:
smbtorture base.delete.deltest20

Expected Results:
pass

Actual Results:
fail

History

#1

Updated by Gordon Ross 5 months ago

  • Description updated (diff)
  • Status changed from New to In Progress
#2

Updated by Gordon Ross 5 months ago

Testing: per. description
Fix in production since early 2018

#3

Updated by Electric Monk 5 months ago

  • Status changed from In Progress to Closed
  • % Done changed from 0 to 100

git commit a1096253735019dce07e79caf2df1e13078770fb

commit  a1096253735019dce07e79caf2df1e13078770fb
Author: Gordon Ross <gwr@nexenta.com>
Date:   2019-05-29T22:07:47.000Z

    10988 SMB should not create in directories marked delete-on-close
    Reviewed by: Matt Barden <matt.barden@nexenta.com>
    Reviewed by: Evan Layton <evan.layton@nexenta.com>
    Approved by: Garrett D'Amore <garrett@damore.org>

Also available in: Atom PDF