Project

General

Profile

Bug #10989

Ricoh scanner error after DFS get referral

Added by Gordon Ross 5 months ago. Updated 5 months ago.

Status:
Closed
Priority:
Normal
Assignee:
Category:
-
Start date:
2019-05-14
Due date:
% Done:

100%

Estimated time:
Difficulty:
Medium
Tags:
needs-triage

Description

Description: Users attempting to save scanned docs from a Ricoh 4002 to a cifs share get an error message and crash the scanner.

Steps to Reproduce:
Configure scanner for smb w/ad authentication; Configure CIFS share with appropriate perm/acls; attempt to save a scanned image

Expected Results: pdf is created on cifs share

Actual Results: scanner crashes

History

#1

Updated by Gordon Ross 5 months ago

  • Description updated (diff)
  • Status changed from New to In Progress
#2

Updated by Gordon Ross 5 months ago

This client expects that an error return from transact2 get_dfs_referral API should come wrapped in an error status at the SMB level. Simple change to set the SMB error as well.

#3

Updated by Gordon Ross 5 months ago

Fix verified at customer.
Fix in production since mid 2017

#4

Updated by Electric Monk 5 months ago

  • Status changed from In Progress to Closed
  • % Done changed from 0 to 100

git commit 810e978011ea80127b0a15368276459b566a3241

commit  810e978011ea80127b0a15368276459b566a3241
Author: Gordon Ross <gwr@nexenta.com>
Date:   2019-05-29T22:07:47.000Z

    10989 Ricoh scanner error after DFS get referral
    Reviewed by: Evan Layton <evan.layton@nexenta.com>
    Reviewed by: Dan Fields <dan.fields@nexenta.com>
    Approved by: Garrett D'Amore <garrett@damore.org>

Also available in: Atom PDF