Project

General

Profile

Bug #10997

Incorrect directory listing response for non-UNICODE clients

Added by Gordon Ross 5 months ago. Updated 4 months ago.

Status:
Closed
Priority:
Normal
Assignee:
Category:
-
Start date:
2019-05-14
Due date:
% Done:

100%

Estimated time:
Difficulty:
Medium
Tags:
needs-triage

Description

When connecting via NetBIOS from a AIX clien, the SMB server is creating malformed packets

Steps to Reproduce:
connect from AIX Client (older smb client using only netbios)
connection works try ls once it doesn't show anything even if the folder has files in it.
do a second ls and you get an error that ls doesn't find "."

Expected Results:
ls should show the files

History

#1

Updated by Gordon Ross 5 months ago

  • Description updated (diff)
  • Status changed from New to In Progress
#2

Updated by Gordon Ross 5 months ago

  • Description updated (diff)
#3

Updated by Gordon Ross 5 months ago

Support for "OEM" (8-bit) character sets was apparently never quite right. Reworked.

#4

Updated by Gordon Ross 5 months ago

Testing: Verified at the customer

Here's a second way to reproduce and verify a fix:
a: Turn off Unicode support in the server
echo 'smb1_server_capabilities/W8000f3f8' |mdb -kw
b: List the directory with smbclient (from Samba)
smbclient -U myuser%mypass //myserver/myshare -c dir
Without the fix, it fails after zero or one directory entries.

Fix in production since late 2015

#5

Updated by Electric Monk 4 months ago

  • Status changed from In Progress to Closed
  • % Done changed from 0 to 100

git commit 07a6ae61f8958faa11352bf1b552d85d79e9cbbe

commit  07a6ae61f8958faa11352bf1b552d85d79e9cbbe
Author: Gordon Ross <gwr@nexenta.com>
Date:   2019-06-04T02:09:35.000Z

    10997 Incorrect directory listing response for non-UNICODE clients
    Reviewed by: Matt Barden <Matt.Barden@nexenta.com>
    Reviewed by: Kevin Crowe <kevin.crowe@nexenta.com>
    Approved by: Richard Lowe <richlowe@richlowe.net>

Also available in: Atom PDF