Project

General

Profile

Feature #10998

SMB should support enhanced Unicode

Added by Gordon Ross 5 months ago. Updated 5 months ago.

Status:
Closed
Priority:
Normal
Assignee:
Category:
-
Start date:
2019-05-14
Due date:
% Done:

0%

Estimated time:
Difficulty:
Medium
Tags:
needs-triage

Related issues

Is duplicate of illumos gate - Feature #7587: SMB should support enhanced UnicodeClosed2016-11-16

Actions

History

#1

Updated by Gordon Ross 5 months ago

  • Status changed from New to In Progress

Customer experienced a problem when a Windows 10 user, mounting a CIFS share attempted to copy files to the folder that contained unicode characters, in this case a Fire Symbol and another file containing the Speaker Symbol.

The files do not appear in the Windows Explorer, however when the user attempts to copy the "missing" files, Windows complains that the files already exist.

Steps to Reproduce: Take the attached zip file (unicode.zip) and copy to a Windows client. Unpack the data to a local NTFS filesystem and observe the Fire and Speaker symbols in two of the filenames.

Map a share from the appliance, then copy the data across. You'll notice no error during the copy but the data is not displayed.
When I attempted to recopy the "missing" files, I got an error from Windows that said it 'Could not find this item' which is different to the customer, but still problematic.

Expected Results: Customer expects the appliance to handle files with unicode in them

Actual Results: The files end up on the ZFS filesystem, but there's no way to view these from the CIFS client.

#2

Updated by Gordon Ross 5 months ago

Duplicate of #7587 Different SMB and ZFS behavior on emoji symbols

#3

Updated by Gordon Ross 5 months ago

  • Status changed from In Progress to Closed
#4

Updated by Gordon Ross 5 months ago

  • Is duplicate of Feature #7587: SMB should support enhanced Unicode added

Also available in: Atom PDF