Project

General

Profile

Bug #11008

SMB1 Create_Temp should return an untagged ASCII string

Added by Gordon Ross 5 months ago. Updated 4 months ago.

Status:
Closed
Priority:
Normal
Assignee:
Category:
-
Start date:
2019-05-14
Due date:
% Done:

100%

Estimated time:
Difficulty:
Medium
Tags:
needs-triage

Description

Discovered during SMB3 durable handles testing:
smbtorture uses "SMB Create Temp" (an SMB1 function), and complains about the response we send.

Steps to Reproduce:
run smbtorture's base.open.ctemp test
Look at the responses with Wireshark

Expected Results:
Our SMB Create Temp response should decode without complaint.
Test should always successfully open, close, and unlink the file

Actual Results:
Test fails to close and unlink the file because the path in the response is garbled, and fails to open the file on subsequent tests

History

#1

Updated by Gordon Ross 5 months ago

  • Description updated (diff)
  • Status changed from New to In Progress

Our SMB Create Temp response has a "tag" (data type used in other SMB responses) where there should be none.

Testing: per description
Fix in production since early 2016

#2

Updated by Electric Monk 4 months ago

  • Status changed from In Progress to Closed
  • % Done changed from 0 to 100

git commit 22817ac489e23ecc1f2daa27fb473985d01ee88b

commit  22817ac489e23ecc1f2daa27fb473985d01ee88b
Author: Matt Barden <matt.barden@nexenta.com>
Date:   2019-06-08T03:01:40.000Z

    11008 SMB1 Create_Temp should return an untagged ASCII string
    Reviewed by: Gordon Ross <gwr@nexenta.com>
    Approved by: Garrett D'Amore <garrett@damore.org>

Also available in: Atom PDF