Project

General

Profile

Feature #11012

SMB resilient handle lock replay

Added by Gordon Ross 5 months ago. Updated 4 months ago.

Status:
Closed
Priority:
Normal
Assignee:
Category:
-
Start date:
2019-05-14
Due date:
% Done:

100%

Estimated time:
Difficulty:
Medium
Tags:
needs-triage

Description

Now that we implement SMB2/3 durable handles (#11011), we need to also implement SMB2/3 lock "replay". This feature is expected with durable handles.

Steps to Reproduce:
smbtorture -U user%pass //server/share smb2.lock.replay

Expected Results:
pass

Actual Results:
fail

History

#1

Updated by Gordon Ross 5 months ago

  • Description updated (diff)
  • Status changed from New to In Progress

Fix in production since mid 2016

#2

Updated by Electric Monk 4 months ago

  • Status changed from In Progress to Closed
  • % Done changed from 0 to 100

git commit 6f58980a389cc62f07e5f2673629d9e9a209c2de

commit  6f58980a389cc62f07e5f2673629d9e9a209c2de
Author: Gordon Ross <gwr@nexenta.com>
Date:   2019-06-08T03:01:40.000Z

    11012 SMB resilient handle lock replay
    Reviewed by: Matt Barden <matt.barden@nexenta.com>
    Reviewed by: Kevin Crowe <kevin.crowe@nexenta.com>
    Approved by: Garrett D'Amore <garrett@damore.org>

Also available in: Atom PDF