Project

General

Profile

Feature #11020

want SMB2 ioctl FSCTL_SRV_COPYCHUNK

Added by Gordon Ross 3 months ago. Updated about 2 months ago.

Status:
Closed
Priority:
Normal
Assignee:
Category:
-
Start date:
2019-05-15
Due date:
% Done:

100%

Estimated time:
Difficulty:
Medium
Tags:
needs-triage

Description

Support the (optional) SMB2 ioctl/fsctl calls:
FSCTL_SRV_COPYCHUNK and
FSCTL_SRV_REQUEST_RESUME_KEY

Steps to Reproduce:
smbtorture ... smb2.ioctl.copy_chunk*

Expected Results:
pass (or mostly so)

Actual Results:
not implemented.

History

#1

Updated by Gordon Ross 3 months ago

  • Description updated (diff)
  • Status changed from New to In Progress

Testing: per the description.
Fix in production since mid 2016

#2

Updated by Electric Monk about 2 months ago

  • Status changed from In Progress to Closed
  • % Done changed from 0 to 100

git commit 55f0a249fd3511728b02627190771a4ce4ddf20e

commit  55f0a249fd3511728b02627190771a4ce4ddf20e
Author: Gordon Ross <gwr@nexenta.com>
Date:   2019-07-06T02:37:20.000Z

    11020 want SMB2 ioctl FSCTL_SRV_COPYCHUNK
    Reviewed by: Evan Layton <evan.layton@nexenta.com>
    Reviewed by: Matt Barden <matt.barden@nexenta.com>
    Reviewed by: Kevin Crowe <kevin.crowe@nexenta.com>
    Reviewed by: Yuri Pankov <yuri.pankov@nexenta.com>
    Approved by: Garrett D'Amore <garrett@damore.org>

Also available in: Atom PDF