Project

General

Profile

Bug #11030

SMB2 ioct dfs_get_referral returns wrong error

Added by Gordon Ross 3 months ago. Updated 10 days ago.

Status:
Closed
Priority:
Normal
Assignee:
Category:
-
Start date:
2019-05-15
Due date:
% Done:

100%

Estimated time:
Difficulty:
Medium
Tags:
needs-triage

Description

Most clients don't care, but we return
NT_STATUS_NO_SUCH_DEVICE
where we should return
NT_STATUS_FS_DRIVER_REQUIRED

It turns out the MS Hyper-V cares which error we return.

Steps to Reproduce:
Connect from any windows client and capture network traffic on port 445.
Look at the capture with Wireshark, and see the SMB2 ioctl (typically
just after a tree connect for a disk share) and its error code.

Expected Results:
NT_STATUS_FS_DRIVER_REQUIRED

Actual Results:
NT_STATUS_NO_SUCH_DEVICE

History

#1

Updated by Gordon Ross 3 months ago

  • Description updated (diff)
  • Status changed from New to In Progress

Tested using Hyper-V as the SMB client.
Fix in production since late 2017

#2

Updated by Gordon Ross about 1 month ago

This (and several other fixes) are up in a PR now:
https://github.com/illumos/illumos-gate/pull/62

#3

Updated by Electric Monk 10 days ago

  • Status changed from In Progress to Closed
  • % Done changed from 0 to 100

git commit 4f7f6babe29cc8387cc404ff3a766f592117778a

commit  4f7f6babe29cc8387cc404ff3a766f592117778a
Author: Gordon Ross <gwr@nexenta.com>
Date:   2019-08-10T14:06:43.000Z

    11030 SMB2 ioct dfs_get_referral returns wrong error
    Reviewed by: Matt Barden <matt.barden@nexenta.com>
    Reviewed by: Evan Layton <evan.layton@nexenta.com>
    Approved by: Garrett D'Amore <garrett@damore.org>

Also available in: Atom PDF