Project

General

Profile

Bug #1107

nfs_tbind.c do_one() function can't work with loopback

Added by Dan Kruchinin over 8 years ago. Updated over 8 years ago.

Status:
Resolved
Priority:
Normal
Assignee:
Category:
nfs - NFS server and client
Start date:
2011-06-13
Due date:
% Done:

0%

Estimated time:
Difficulty:
Medium
Tags:
needs-triage

Description

Network lock manager has a lockd daemon that uses nfs_tbind.c do_one() function to
register XTI/TLI provider device (/dev/tcp, /dev/udp, etc) for polling and associate with it netconfig and netid. The problem is lockd needs to use loopback device (/dev/ticotsord provider) for communication with kernel part of network lock manager.
do_one() function wasn't designed to work with loopback, it's a problem.


Files

nfs_bind.patch (1.29 KB) nfs_bind.patch Dan Kruchinin, 2011-06-13 02:11 AM

History

#1

Updated by Dan Kruchinin over 8 years ago

Patch attached.
The patch allows do_one() to handle loopback device properly.
It also fixes memleak in do_one function (function calls set_addrmask which allocates space for buffer and it doesn't frees buffer then).

#2

Updated by Eric Schrock over 8 years ago

  • Status changed from New to Resolved

changeset: 13391:e851229134c9
tag: tip
user: Dan Kruchinin <>
date: Mon Jun 20 07:27:51 2011 -0700

description:
1107 nfs_tbind.c do_one() function can't work with loopback
Reviewed by: Gordon Ross <>
Reviewed by: Dan McDonald <>
Approved by: Eric Schrock <>

Also available in: Atom PDF