Project

General

Profile

Bug #1114

text installer not booting when disabling on-board NIC

Added by Wilrik Mook almost 9 years ago. Updated almost 9 years ago.

Status:
Closed
Priority:
Normal
Assignee:
Category:
Caiman (Installer)
Target version:
-
Start date:
2011-06-14
Due date:
% Done:

0%

Estimated time:
Difficulty:
Medium
Tags:
grub video

Description

For my home server, I would like to try OI. But when disabling the on-board NIC in the bios (because I have an Intel pci-e card), the installation images fail to boot. All that is visible are two blue-ish bars on the top and bottom of the screen. When I enable the NIC again, they boot to the installer just fine. With they, I mean I have tried the following usb images: OI 148, OI 151 dev, OSOL 134 and even S11EX. They all fail to even show the GRUB boot message (3 second countdown) when the on-board NIC is disabled.

My hardware is as follows:
MSI H67MA-E45 (with the to-disable on-board Realtek RTL8111E)
Intel Core i5 2400 with IGP
16 GB ram
(disks don't really matter I suppose)

I will try my best to provide additional information when needed.


Files

live_after_grub_menu.JPG (2.39 MB) live_after_grub_menu.JPG Wilrik Mook, 2011-06-23 07:28 PM
text_no_grub.JPG (2.55 MB) text_no_grub.JPG Wilrik Mook, 2011-06-23 07:28 PM
text_no_grub_wait.JPG (2.47 MB) text_no_grub_wait.JPG Wilrik Mook, 2011-06-23 07:28 PM

History

#1

Updated by Chris Jordan almost 9 years ago

  • Category set to Caiman (Installer)
  • Status changed from New to Feedback
  • Assignee set to Chris Jordan
  • Tags changed from needs-triage to grub

We're glad to hear you would like to try OI, but I'm afraid we aren't going to be able to help you much with this issue. I would suggest you try three things:

1. Since it does boot with the onboard NIC enabled, just leave it enabled. It's often very useful to have multiple NICs anyway.

If that isn't possible, then:

2. Make sure you are using the most current bios version for that motherboard. I see that there have been several revisions this year, although I don't see any that directly apply, it may be that there is a fix in one of them.

If that doesn't help, then:

3. It would be interesting to see if a Linux distribution that also uses GRUB 1 also fails when the onboard NIC is disabled.

#2

Updated by Wilrik Mook almost 9 years ago

Some background information: the reason why I would like to disable the NIC was that I couldn't make it work properly. rge identifies the NIC but ip stays 0.0.0.0 or when set statically it's not pingable, and installing gani would tell me "driver (gani) installed correctly but failed to attach" or something similar. I guess that is a different story, but it is the reason I bought an Intel CT Desktop card instead (also less cpu load I suppose).

As for your suggestions:

1. see above
2. I am using the latest bios version
3. this was suggested to me on IRC too; Ubuntu Hardy 8.04 displays GRUB and starts its installer just fine

So I decided to install 148 with the NIC enabled. After installing, I disabled it and this poses no problems!Seems I am only experiencing it with the installers. So it is not a big issue, but there must be a bug somewhere.

#3

Updated by Chris Jordan almost 9 years ago

That is great you found a way to work around the problem. Let me make sure I understand - to summarize:

1. When you have the onboard NIC disabled in the bios on your MSI H67MA-E45 motherboard the installation image won't boot. You said you tried a bunch of them, were you just trying the text installer, oi-dev-148-text-x86.iso, or were you also trying oi-dev-148-x86.iso? Did you happen to try the live usb?

2. When it fails to boot it hangs before GRUB prints anything on the screen, and there are just two blue-ish bars on the top and bottom of the screen? Normally GRUB would print an error, I wonder if it's not really getting to GRUB at all or if there's some odd video issue going on.

3. With the onboard NIC enabled you were able to boot the installation image and install OpenIndiana 148 fine. You were then able to disable the onboard NIC and boot off the installed OpenIndiana 148 fine.

#4

Updated by Wilrik Mook almost 9 years ago

I've added some photographical evidence, to illustrate things a bit better.

1. Correct, though the result of the live usb image is a bit different: a visible GRUB menu! But after that, well ... see the first photo. With the NIC enabled, the live image starts as it should.

2. Correct, and having seen the results from the live usb image, it looks like a video issue indeed. See the 2nd attached photo for the results of the text installer. The third photo is taken after waiting idle for a bit.

3. Correct, this is after installing from the live usb image.

Fun fact: I tried removing the progress bar splash from the installed system, but this results in the appearance of the same red spots as shown above (removed 'splashimage', 'foreground', 'background' lines and 'console=graphics' from the kernel GRUB entry).
So, I now have some new visual effects: red spots! It would seem that this is indeed some kind of graphical issue, but otherwise graphics are working just fine, as far as I can see.

Now, I got my working system, but if this is a bug that should be squished, I will try to provide as much as info as possible. Thank you for listening!

#5

Updated by Chris Jordan almost 9 years ago

  • Status changed from Feedback to Closed
  • Tags changed from grub to grub video

Nicely troubleshot Wilrik. It seems to me that when your onboard NIC is disabled neither Grub nor Solaris can display video that is supposed to be in text mode. So when you remove the splashimage from Grub it tries to use text-mode, and you see the garbage on your screen instead of text. That wasn't a problem when you tried Ubuntu because the Ubuntu live cd never tries to do that, it's graphical all the time. I've read that motherboard's bios configuration screens are as well. Since you have a workaround, and since it seems like a motherboard/bios problem, I'm going to close this ticket. Thanks for your help.

Also available in: Atom PDF