Project

General

Profile

Bug #1115

kcf should possibly depend upon swrand

Added by Rich Lowe over 8 years ago. Updated over 8 years ago.

Status:
Closed
Priority:
Normal
Assignee:
-
Category:
kernel
Start date:
2011-06-15
Due date:
% Done:

0%

Estimated time:
Difficulty:
Medium
Tags:
needs-triage

Description

The "No randomness provider enabled" message at boot time seems to be caused by KCF initializing its randomness prior to swrand getting started.

It's possible that KCF should depend on swrand, such that the software provider always exists prior to KCF calling kcf_rnd_init() (ultimately called via kcf`_init).

I've done very little investigation here, and anyone doing this should be cautious to avoid introducing circular dependencies. This is especially subtle as kcf may be loaded very early in the case of network boot.


Related issues

Is duplicate of illumos gate - Bug #995: boot message: No randomness provider enabled for /dev/randomResolved2011-05-06

Actions

History

#1

Updated by Rich Lowe over 8 years ago

  • Status changed from New to Closed

Dup of #995

Also available in: Atom PDF