Project

General

Profile

Actions

Bug #1118

open

/dev-il illumos version will break illumos onu

Added by Rich Lowe about 11 years ago. Updated over 7 years ago.

Status:
New
Priority:
High
Assignee:
Category:
-
Start date:
2011-06-16
Due date:
% Done:

0%

Estimated time:
Difficulty:
Medium
Tags:
Gerrit CR:

Description

In the /dev-il repo the build version of illumos was incremented to 0.151, to match everything else. Because in the illumos source tree the packages remain at 0.148, this means that any packages built from our source tree will no longer install on OI. It'd be nice to avoid that.

The problem is that if you keep our current version number, people running oi_148 will get the upgrade, because the incorporations aren't (and perhaps can't be) tight enough to prevent it.

Solutions I can think of are:

  1. Leave illumos version at 0.148, trust that we have done nothing incompatible, and that we'll bump that number if we do
  2. Have illumos bump their version to match yours, and continue to do so (I'm against this)
  3. Have illumos bump their version far past you, and give you your own space to play in, as long as you never catch back up and screw it again (ie, call illumos 1.0, and leave you guys with 0.* in which to play). This is probably the smoothest solution, but I'm sure people will argue about the merits of calling something "1.0", even in a place nobody really looks.

Related issues

Related to illumos gate - Feature #7997: Could make nightly env files more easily usableIn ProgressRich Lowe2017-03-22

Actions
Actions

Also available in: Atom PDF