Project

General

Profile

Bug #11201

zfs test zpool_create_020_pos leaves a directory behind

Added by Kody Kantor 4 months ago. Updated 4 months ago.

Status:
Closed
Priority:
Normal
Assignee:
Category:
zfs - Zettabyte File System
Start date:
Due date:
% Done:

100%

Estimated time:
Difficulty:
Bite-size
Tags:

Description

The zpool_create_020_pos test leaves behind a directory at /testpool.root, likely due to a copy/paste error. On subsequent test runs, this directory being present when the test begins causes the test to fail.

History

#1

Updated by Kody Kantor 4 months ago

To test this I created a runfile that only ran the test in question. It passes consistently after this change.

$ ./zfstest -c ../kkantor.run
Test: /opt/zfs-tests/tests/functional/cli_root/zpool_create/setup (run as root) [00:05] [PASS]
Test: /opt/zfs-tests/tests/functional/cli_root/zpool_create/zpool_create_020_pos (run as root) [00:00] [PASS]
Test: /opt/zfs-tests/tests/functional/cli_root/zpool_create/cleanup (run as root) [00:00] [PASS]

Results Summary
PASS 3

Running Time: 00:00:07
Percent passed: 100.0%
Log directory: /var/tmp/test_results/20190605T160902

#2

Updated by Electric Monk 4 months ago

  • Status changed from New to Closed
  • % Done changed from 0 to 100

git commit 6c97119c7cb695abdfe81ac4b666f5c67eb77ed7

commit  6c97119c7cb695abdfe81ac4b666f5c67eb77ed7
Author: Kody Kantor <kody@kkantor.com>
Date:   2019-06-06T03:59:06.000Z

    11201 zfs test zpool_create_020_pos leaves a directory behind
    Reviewed by: John Kennedy <john.kennedy@delphix.com>
    Reviewed by: Toomas Soome <tsoome@me.com>
    Reviewed by: Jerry Jelinek <jerry.jelinek@joyent.com>
    Approved by: Dan McDonald <danmcd@joyent.com>

Also available in: Atom PDF