Project

General

Profile

Bug #11235

make -C fails under GCC7

Added by John Levon over 1 year ago. Updated over 1 year ago.

Status:
Closed
Priority:
Normal
Assignee:
Category:
-
Start date:
Due date:
% Done:

100%

Estimated time:
Difficulty:
Medium
Tags:
Gerrit CR:

Description

When build with GCC7, make -C core dumps with:

$C

08040ce8 maybe_append_prop+0xc(0, 3, 0, 0, 4, 807b008)
08040d28 enter_argv_values+0x2a9(4, 8044734, 8040d7c, 0, 8ca3100, 8ca30b0)
080446c8 main+0xef7(80446cc, fe3eb348, 8044708, 8059017, 4, 8044734)
08044708 _start_crt+0x96(4, 8044734, f4bec926, 0, 0, 0)
08044728 _start+0x1a(4, 804495c, 0, 0, 804496a, 0)

History

#1

Updated by John Levon over 1 year ago

The problem is that we were never setting 'name' at all, so we fall over with a NULL deference. It likely worked previously as gcc4 is a lot slacker about NULL "this", but I haven't tried to confirm.

#2

Updated by Electric Monk over 1 year ago

  • Status changed from New to Closed
  • % Done changed from 0 to 100

git commit 32106ed6e3cf48fafbdcc54953821f590bc7b50b

commit  32106ed6e3cf48fafbdcc54953821f590bc7b50b
Author: John Levon <john.levon@joyent.com>
Date:   2019-06-14T17:10:58.000Z

    11235 make -C fails under GCC7
    Reviewed by: Robert Mustacchi <rm@joyent.com>
    Reviewed by: Richard Lowe <richlowe@richlowe.net>
    Approved by: Dan McDonald <danmcd@joyent.com>

Also available in: Atom PDF