Project

General

Profile

Bug #1135

intel driver stops updating the screen sometimes

Added by Albert Lee over 8 years ago. Updated almost 8 years ago.

Status:
Resolved
Priority:
Normal
Assignee:
Category:
XNV (X Window System)
Target version:
Start date:
2011-06-21
Due date:
2011-09-14
% Done:

100%

Estimated time:
40.00 h
Difficulty:
Hard
Tags:
xnv

Description

Since upgrading from 148a to our current 151 prerelease, I've had my X desktop appear to freeze once every few days, although the hardware cursor would continue to update on top of it. I had to restart the X server each time this happens. I'm using the intel driver on a "IGDNG_M": pci bus 0x0000 cardnum 0x02 function 0x00: vendor 0x8086 device 0x0046
Intel Corporation Core Processor Integrated Graphics Controller
embedded in a U3400 CULV processor.

Nothing is written to the X server log at the time.


Files

Xorg.0.log.old (25.5 KB) Xorg.0.log.old Albert Lee, 2011-06-22 07:12 AM
Xorg.0.log.old (13.5 KB) Xorg.0.log.old Marion Hakanson, 2011-10-05 04:49 PM

Related issues

Related to OpenIndiana Distribution - Bug #1161: oi_151 32 bits nVidia driver freezes the machineClosed2011-06-282011-09-14

Actions

History

#1

Updated by Julian Wiesener over 8 years ago

Hi,

can you attach the Xorg.0.log, thus we see what exact Hardware is involved?

I've little doubts, that the problem is new, i have similar issues from time to time (somtimes once per week, somtimes after a few months), for a long time (<osol-130).

Please do the Following Test when it's hanging next time:
remote login from ssh, restart gdm. Look out for changes on the screen (may be it just appears garbage, however Xorg starts just fine).
If the Screen is not working after restart, try a fast-reboot using init 6.

In the case i have here, even an init 6 does not solve the problem, i see something from the console thru a pixel puzzel, but to get a really working screen again i've to power off.

Using google-maps may be a way to trigger the issue, i assume everything that does much 2d graphic would.

#2

Updated by Albert Lee over 8 years ago

Julian Wiesener wrote:

Hi,

can you attach the Xorg.0.log, thus we see what exact Hardware is involved?

I've little doubts, that the problem is new, i have similar issues from time to time (somtimes once per week, somtimes after a few months), for a long time (<osol-130).

Please do the Following Test when it's hanging next time:
remote login from ssh, restart gdm. Look out for changes on the screen (may be it just appears garbage, however Xorg starts just fine).
If the Screen is not working after restart, try a fast-reboot using init 6.

In the case i have here, even an init 6 does not solve the problem, i see something from the console thru a pixel puzzel, but to get a really working screen again i've to power off.

Using google-maps may be a way to trigger the issue, i assume everything that does much 2d graphic would.

I'm probably experiencing a different problem; it's much harder to reproduce and the symptoms aren't quite the same. The X server continues to update the cursor (pointer) correctly when I move the mouse/touchpad, but the rest of the screen remains static. I enabled virtual consoles and can VT switch to the first console and back to X. The X sceen is then grey, while the cursor is still visible and working on the laptop screen but not on the external monitor now.

The X server restarts correctly if I restart GDM from the console.

I just noticed that the driver actually logs an error trying to set up the mappings when I VT switch back, it's in the attached log.

By the way, I understand our Intel DRM (i915) has GEM support but it seems to be disabled at build time in the Xorg driver? Do you know why?

#3

Updated by Julian Wiesener over 8 years ago

  • Target version set to oi_151_stable
#4

Updated by Albert Lee over 8 years ago

There are reports of similar symptoms on NVIDIA graphics, which suggests the root cause may be in compiz.

#5

Updated by Alex Viskovatoff over 8 years ago

I don't think compiz is to blame. I experienced the same problem when playing videos with mplayer2 using VDPAU but running XMonad, not compiz, as my window manager. After I tried using compiz, X froze in the same way. My GPU is an Nvidia GeForce 210.

I thought this problem lay with a bug in the Nvidia driver, but now that I see from this bug report that it also occurs with the Intel driver, I am not so sure.

#6

Updated by Ken Mays about 8 years ago

  • Status changed from New to Feedback
  • % Done changed from 0 to 100

Aszesno updated Nvidia driver to 280.13 and mentioned same problem was fixed. Need user's feedback for verification.

#7

Updated by Nikola M. about 8 years ago

I have trouble with screen freezing since OpenSolaris snv_132 onwards (latest was snv_131 to work without freezing and I still have that BE at my machine).
Bug is present in everything past that release, including Solaris11Express (I also have its'BE) and latest /dev-il OI_151b with Illumos.
Latest info from Oracle bug database I got before closing was that the bug was marked as to be fixed in the next X server release/update. (I think bugs 6936915 and 6933951: X server freezing on Intel Graphics Nbook i915)

My Hardware, par example, is Notebook Dell Latitude D620 with Intel Graphics (945G with i915 driver).
Newest behavior is what I witnessed today, to see cursor moving with picture freeze.

#8

Updated by Albert Lee about 8 years ago

  • Status changed from Feedback to New
#9

Updated by Ken Mays about 8 years ago

  • Due date set to 2011-09-14
  • % Done changed from 100 to 0
  • Estimated time set to 40.00 h

Replicated XServer full screen freeze with moving cursor on oi_151a within 1-2 minutes of running glxgears in four different Xwindows with compiz fully enabled. Same bug was not reproduced using the exact same procedure using oi_148b (using Nvidia 256.44 (default) and compiz fully enabled) for a 15 minute OpenGL demo. Please check if Xnv_151 was compiled with SS 12.1 as the primary compiler which can produce faulty executables (if not patched correctly with recent compiler patches or using correct compiler flags).

#10

Updated by Alasdair Lumsden about 8 years ago

  • Status changed from New to In Progress

This is probably a duplicate of #1127 - Xorg was built with Sun Studio 12.1 instead of 12.0 which has a bug. Will respin XNV for the release.

#11

Updated by Alan Coopersmith about 8 years ago

Ken Mays wrote:

Please check if Xnv_151 was compiled with SS 12.1 as the primary compiler which can produce faulty executables (if not patched correctly with recent compiler patches or using correct compiler flags).

Already confirmed this with Alasdair on IRC, but for those who weren't there, the X build doesn't strip out the compiler information, so anyone with a binary can check for themselves by running mcs -p. Alasdair checked his and found that 12.1 was indeed used:

alasdair ~ (ninja.rar): uname -a
SunOS ninja.rar 5.11 oi_151a i86pc i386 i86pc Solaris
alasdair ~ (ninja.rar): mcs -p /usr/bin/amd64/Xorg
/usr/bin/amd64/Xorg:
acomp: Sun C 5.10 SunOS_i386 Patch 142363-03 2009/12/03
iropt: Sun Compiler Common 12.1 SunOS_i386 Patch 141858-04 2009/12/08
ir2hf: Sun Compiler Common 12.1 SunOS_i386 Patch 141858-04 2009/12/08
ube: Sun Compiler Common 12.1 SunOS_i386 Patch 141858-04 2009/12/08
as: Sun Compiler Common 12.1 SunOS_i386 Patch 141858-04 2009/12/08
%Z%%M%    %I%    %E% SMI
@(#)math.h    2.26    08/09/11 SMI
@(#)math_iso.h    1.10    05/10/06 SMI
@(#)math_c99.h    1.12    07/01/21 SMI
@(#)floatingpoint.h    2.12    07/05/17 SMI
@(#)ieeefp.h    2.13    05/10/06 SMI

@(#)SunOS 5.11 oi_148b March 2011
ld: Software Generation Utilities - Solaris Link Editors: 5.11-1.1726
@(#)xorg-server 1.7.7   (hg: nv_151 - 22 May 2011)
#12

Updated by Ken Mays about 8 years ago

Please image-update to the latest dev-il (09/12) packages. Xnv was rebuilt with SS 12.

,5.11-0.151.1:20110912T032745Z

/usr/X11/bin/i386/Xorg:
acomp: Sun C 5.9 SunOS_i386 Patch 124868-10 2009/04/30
iropt: Sun Compiler Common 12 SunOS_i386 Patch 126498-13 2009/04/06
ir2hf: Sun Compiler Common 12 SunOS_i386 Patch 126498-13 2009/04/06
ube: Sun Compiler Common 12 SunOS_i386 Patch 126498-13 2009/04/06
as: Sun Compiler Common 12 SunOS_i386 Patch 126498-13 2009/04/06
%Z%%M%  %I%     %E% SMI
@(#)math.h      2.26    08/09/11 SMI
@(#)math_iso.h  1.10    05/10/06 SMI
@(#)math_c99.h  1.12    07/01/21 SMI
@(#)floatingpoint.h     2.12    07/05/17 SMI
@(#)ieeefp.h    2.13    05/10/06 SMI

@(#)SunOS 5.11 oi_151a August 2011
 cpp: Software Generation Utilities (SGU) SunOS/SVR4
ld: Software Generation Utilities - Solaris Link Editors: 5.11-1.1726
@(#)xorg-server 1.7.7   (hg: 6ba2ea078395 - 11 Sep 2011)

Requesting user feedback for resolution.

#13

Updated by Ken Mays about 8 years ago

  • Status changed from In Progress to Feedback
  • % Done changed from 0 to 90
#14

Updated by Ken Mays about 8 years ago

  • % Done changed from 90 to 100
  • Tags changed from needs-triage to xnv

Same X11 'freeze' bug was not reproduced using oi_151a 09/12/11 edition (using Nvidia 280.13/Nvidia GeForce Go 7600) during a full 60 minutes of tests. Compiz enabled in 'Visual Effects Extras mode'.

Same X11 'freeze' bug was not reproduced using oi_151a 09/12/11 edition (using Intel 2.6.3/Intel Brookdale 865G GPU during a full 30 minutes of tests. Compiz enabled in 'Visual Effects Extras mode'. GEM enabled.

Alex V. verified VLC/VDPAU video issues were fixed in this update. This ticket resolves the related Nvidia driver freezes Xserver issues observed in the other duplicate tickets.

Ticket resolved.

#15

Updated by Ken Mays about 8 years ago

  • Status changed from Feedback to Resolved
#16

Updated by Marion Hakanson about 8 years ago

This Xorg freeze (or one exactly like what's described in issue 1161/1127) is still happening on two of my systems. Both run OI-151a now, and both have the nVidia driver version 280.13; The crash also happened under OI-148 with the same nVidia driver. One machine is 64-bit Intel Core i7 w/8GB RAM, GeForce 7300GT; The other is 32-bit Intel P4 w/2GB RAM, GeForce 6200.

When the problem occurs, mouse and keyboard input are ignored, but one can log remotely. You see the Xorg process using 100% CPU; Actually it shows in "prstat -m" as 33% USR, 33% LCK, 33% SLP. Usually restarting gdm is not sufficient, I think the nVidia card or driver is in an unhappy state, with some blocks of black & white bars on the screen after Xorg exits, so I usually just reboot the system.

Also, the Xorg.0.log shows entries like the ones below at the end, prior to killing it.

(WW) Oct 04 10:24:40 NVIDIA: WAIT (2, 6, 0x8000, 0x0000c290, 0x0000ca08)
(WW) Oct 04 10:24:47 NVIDIA: WAIT (1, 6, 0x8000, 0x0000c290, 0x0000ca08)
. . .

Let me know what kind of debug information I can collect, and how.

#17

Updated by Marion Hakanson about 8 years ago

Oh, in my cases, compiz is enabled.

#18

Updated by Albert Lee about 8 years ago

Marion Hakanson wrote:

This Xorg freeze (or one exactly like what's described in issue 1161/1127) is still happening on two of my systems. Both run OI-151a now, and both have the nVidia driver version 280.13; The crash also happened under OI-148 with the same nVidia driver. One machine is 64-bit Intel Core i7 w/8GB RAM, GeForce 7300GT; The other is 32-bit Intel P4 w/2GB RAM, GeForce 6200.

When the problem occurs, mouse and keyboard input are ignored, but one can log remotely. You see the Xorg process using 100% CPU; Actually it shows in "prstat -m" as 33% USR, 33% LCK, 33% SLP. Usually restarting gdm is not sufficient, I think the nVidia card or driver is in an unhappy state, with some blocks of black & white bars on the screen after Xorg exits, so I usually just reboot the system.

Also, the Xorg.0.log shows entries like the ones below at the end, prior to killing it.

(WW) Oct 04 10:24:40 NVIDIA: WAIT (2, 6, 0x8000, 0x0000c290, 0x0000ca08)
(WW) Oct 04 10:24:47 NVIDIA: WAIT (1, 6, 0x8000, 0x0000c290, 0x0000ca08)
. . .

Let me know what kind of debug information I can collect, and how.

Please open a new bug and include your full log and reproduction instructions. This is unrelated to any of the existing ones.

#19

Updated by Nikola M. almost 8 years ago

I am not sure if this is the same bug ,
but freezing X on oi151 on my hardware (Intel 945, Dell latitude D620) is regular and every day thing. So not fixed for me ATM. (and since snv_132, was still present in S11express)

Also available in: Atom PDF