Project

General

Profile

Bug #1136

Nvidia Geforce 210 causes kernel panick

Added by Jeffrey Baitis over 8 years ago. Updated over 8 years ago.

Status:
Resolved
Priority:
Normal
Category:
Drivers
Target version:
-
Start date:
2011-06-22
Due date:
% Done:

0%

Estimated time:
Difficulty:
Medium
Tags:
nvidia

Description

  • EVGA GeForce 210

openindyraid savecore: [ID 570001 auth.error] reboot after panic: BAD TRAP: type=e (#pf Page fault) rp=ffffff0008d8f760 addr=0 occurred in module "nvidia" due to a NULL pointer dereference

PLATFORM: A760G-M2+, CSN: None, HOSTNAME: openindyraid

TIME UUID SUNW-MSG-ID
Jun 20 2011 12:57:11.573183000 eab9fa54-188a-c703-96df-84d27b52fff8 SUNOS-8000-KL

TIME                 CLASS                                 ENA
Jun 20 12:56:57.9879 ireport.os.sunos.panic.dump_pending_on_device 0x0000000000000000

nvlist version: 0
version = 0x0
class = list.suspect
uuid = eab9fa54-188a-c703-96df-84d27b52fff8
code = SUNOS-8000-KL
diag-time = 1308599831 231476
de = fmd:///module/software-diagnosis
fault-list-sz = 0x1
fault-list = (array of embedded nvlists)
(start fault-list0)
nvlist version: 0
version = 0x0
class = defect.sunos.kernel.panic
certainty = 0x64
asru = sw:///:path=/var/crash/openindyraid/.eab9fa54-188a-c703-96df-84d27b52fff8
resource = sw:///:path=/var/crash/openindyraid/.eab9fa54-188a-c703-96df-84d27b52fff8
savecore-succcess = 0
os-instance-uuid = eab9fa54-188a-c703-96df-84d27b52fff8
panicstr = BAD TRAP: type=e (#pf Page fault) rp=ffffff0008d8f760 addr=0 occurred in module "nvidia" due to a NULL pointer dereference
panicstack = unix:die+dd () | unix:trap+1799 () | unix:cmntrap+e6 () | nvidia:_nv003071rm+16c () |
crashtime = 1308599686
panic-time = June 20, 2011 12:54:46 PM PDT PDT
(end fault-list0)

fault-status = 0x1
severity = Major
__ttl = 0x1
__tod = 0x4dffa617 0x222a1418

History

#1

Updated by Jeffrey Baitis over 8 years ago

Spelling error: "panic" not "panick" sorry

#2

Updated by Garrett D'Amore over 8 years ago

This is a problem in the closed nvidia module that is part of the OpenIndiana distribution. I'm refiling there.

#3

Updated by Garrett D'Amore over 8 years ago

  • Project changed from illumos gate to OpenIndiana Distribution
  • Category deleted (kernel)
#4

Updated by Chris Jordan over 8 years ago

  • Status changed from New to Feedback

Jeffrey Baitis,

What version of OpenIndiana are you running?

Are you able to reproduce the kernel panic, if so how?

#5

Updated by Jeffrey Baitis over 8 years ago

This panic was reproduced on OpenIndiana 148. Unfortunately, I have since RMA'd the video card that generated this error.

Steps to reproduce:

1. change xorg.conf to use "nvidia" driver
2. shutdown
3. insert Nvidia 210 card
4. start machine w/GDM enabled

result: kernel panic

#6

Updated by Julian Wiesener over 8 years ago

  • Category set to Drivers
  • Assignee set to Julian Wiesener
  • Tags changed from needs-triage to nvidia

plese reproduce on 151 once it's out. We've just updated the nvidia driver.

#7

Updated by Alex Viskovatoff over 8 years ago

I just installed an Asus GeForce 210 Silent card, and the system appears to be perfectly stable. I'm running OI 151, and the Nvidia driver version is 275.21.

The only issues I've run into so far involve using mplayer2 with VDPAU, as reported here: https://www.illumos.org/issues/1345. The X server can freeze under certain circumstances, but it can be restarted without a reboot.

#8

Updated by Julian Wiesener over 8 years ago

  • Status changed from Feedback to Resolved

Also available in: Atom PDF