Project

General

Profile

Actions

Bug #11499

closed

default to hires tick

Added by Rich Lowe about 2 years ago. Updated 11 months ago.

Status:
Closed
Priority:
Normal
Assignee:
Category:
kernel
Start date:
Due date:
% Done:

100%

Estimated time:
Difficulty:
Bite-size
Tags:
Gerrit CR:

Description

It's the future, let's default to the high clock resolution.

(Yes, I know tickless would be better)

Actions #1

Updated by Joshua M. Clulow about 2 years ago

Note that Joyent has been running with set hires_tick=1 in /etc/system on all SmartOS systems since ~2013: https://smartos.org/bugview/OS-2572

Actions #2

Updated by Rich Lowe 12 months ago

  • Status changed from New to In Progress
Actions #3

Updated by Electric Monk 11 months ago

  • Gerrit CR set to 864
Actions #4

Updated by Rich Lowe 11 months ago

Testing:

Build, running, build with build running.  Confirmed value of `hz`.  Confirmed value of `hz` when `hires_tick` is explicitly set back 0
Actions #5

Updated by Electric Monk 11 months ago

  • Status changed from In Progress to Closed
  • % Done changed from 0 to 100

git commit d96925c4917df4be0de8533ddaa487c9d915b8c5

commit  d96925c4917df4be0de8533ddaa487c9d915b8c5
Author: Richard Lowe <richlowe@richlowe.net>
Date:   2020-09-10T22:43:06.000Z

    11499 default to hires tick
    Reviewed by: Joshua M. Clulow <josh@sysmgr.org>
    Reviewed by: Andy Fiddaman <andy@omniosce.org>
    Reviewed by: Patrick Mooney <pmooney@pfmooney.com>
    Reviewed by: John Levon <levon@movementarian.org>
    Approved by: Joshua M. Clulow <josh@sysmgr.org>

Actions

Also available in: Atom PDF