Project

General

Profile

Bug #11503

mapfile v2 parser makes versions non-weak incorrectly

Added by Rich Lowe 8 months ago.

Status:
New
Priority:
Normal
Assignee:
-
Category:
tools - gate/build tools
Start date:
Due date:
% Done:

0%

Estimated time:
Difficulty:
Medium
Tags:

Description

Apparently a version declared thus

SYMBOL_VERSION foo {
    protected:
}

is non-weak, despite containing no symbols. It seems like the 'protected:' clause triggers this.

Also available in: Atom PDF