Bug #1161

oi_151 32 bits nVidia driver freezes the machine

Added by Hernán Saltiel almost 3 years ago. Updated over 2 years ago.

Status:Closed Start date:2011-06-28
Priority:High Due date:2011-09-14
Assignee:Andrzej Szeszo % Done:

100%

Category:Drivers
Target version:oi_151 Estimated time:40.00 hours
Difficulty:Medium Tags:xnv

Description

Hi!
When trying to switch from one window to another (system recently installed from oi_151 iso), the entire machine freezes.
From that point, I have no other solution than pressing the power button to do a hardware reset, and start again the machine.
The nVidia card is an old Geforce Go 7400 installed in a laptop (HP DV5000 - 32 bits - Intel Dual Core - 2 GB RAM).
Thanks in advance for your time and attention!
Best regards,

HeCSa.


Related issues

related to OpenIndiana Distribution - Bug #1135: intel driver stops updating the screen sometimes Resolved 2011-06-21 2011-09-14

History

Updated by Ken Mays almost 3 years ago

  • Status changed from New to Feedback
  • Assignee set to Andrzej Szeszo
  • % Done changed from 0 to 50

This was resolved in bug 1127 using Nvidia driver 275.09.07, but need user's feedback on this update.

Updated by Ken Mays almost 3 years ago

User reported hang issue still present. Suggest update to Nvidia 280.xx stable driver series and reported other desktop hardware configs having 'hang' issues.

Updated by Yan-Cheng Zhang almost 3 years ago

maybe this post is related:
http://www.nvnews.net/vbulletin/showthread.php?t=162243

Drivers tested: 256.53, 270.41.19, 275.09.07, 280.04.

I have some problem that playing Wow with wine 1.2.3,

but that 's not happens switching window, but run more app (firefox, termimal), even ramdomly.

at this time, can't do anything (included switch to VT) that move the curser.

ah, at least, still heard the music that played before freezes. :P

Updated by D McD almost 3 years ago

Can confirm this happens to me as well.
AMD Athlon II X4 640
8GB DDR3 1600MHz
Nvidia GTS250
WD 250GB RE3 x2 (mirror)

Hard locks would happen completely randomly. At first I thought it was a RAM issue and spent 2 days memtesting, which all came back clear.

Also after resuming to desktop from a suspend, menus, dialogs etc take a long time to fade in/out, as though the refresh rate is stupidly low, 5FPS for example.

Updated by D McD almost 3 years ago

Scratch that, not convinced that is what's causing my hard locks.

I thought I'd try an older driver so dropped back to console, created a new boot environment, mounted it and went to remove the installed nvidia driver.
Load of text went flying past and what appeared to be a kernel dump?
Machine was hard locked.

Updated by Hernán Saltiel almost 3 years ago

Hi!
Today my gdm hung again.
In /var/log/gdm/:0.log I found this:
X.Org X Server 1.7.7
Release Date: 2010-05-04
X Protocol Version 11, Revision 0
Build Operating System: SunOS 5.11 i86pc
Current Operating System: SunOS battlelloyd-o 5.11 oi_151 i86pc
Build Date: 22 May 2011 05:07:00PM
Solaris ABI: 32-bit
Current version of pixman: 0.18.4
Before reporting problems, check http://openindiana.org/consolidation/xnv
to make sure that you have the latest version.
Markers: (--) probed, (**) from config file, (==) default setting,
(++) from command line, (!!) notice, (II) informational,
(WW) warning, (EE) error, (NI) not implemented, (??) unknown.
(==) Log file: "/var/log/Xorg.0.log", Time: Sat Jul 16 18:03:51 2011
(==) Using default built-in configuration (58 lines)
(EE) Failed to load module "xtsol" (module does not exist, 0)
(EE) Failed to load module "nvda" (module does not exist, 0)
(EE) Failed to load module "fbdev" (module does not exist, 0)
The XKEYBOARD keymap compiler (xkbcomp) reports:

Warning: Multiple names for keycode 155 Using <I150>, ignoring <I1B> Warning: Multiple names for keycode 160 Using <I160>, ignoring <I20> Warning: Multiple names for keycode 235 Using <I235>, ignoring <I6B> Warning: Type "ONE_LEVEL" has 1 levels, but <RALT> has 2 symbols Ignoring extra symbols
Errors from xkbcomp are not fatal to the X server

:0-greeter.log has lots of:

(gnome-settings-daemon:883): atk-bridge-WARNING **: IOR not set.

(gnome-settings-daemon:883): atk-bridge-WARNING **: AT_SPI_REGISTRY was not started at session startup.

(gnome-settings-daemon:883): atk-bridge-WARNING **: IOR not set.

(gnome-settings-daemon:883): atk-bridge-WARNING **: AT_SPI_REGISTRY was not started at session startup.

(gnome-settings-daemon:883): atk-bridge-WARNING **: IOR not set.

(gnome-settings-daemon:883): atk-bridge-WARNING **: AT_SPI_REGISTRY was not started at session startup.

(gnome-settings-daemon:883): atk-bridge-WARNING **: IOR not set.

Thanks!

HeCSa.

Updated by Jon Tibble over 2 years ago

  • Tags deleted (needs-triage)

The driver in /dev-il has been updated to 275.21.

Would be good to get testing and feedback as to which, if any, issues still remain with this driver.

Updated by Ian Johnson over 2 years ago

This appears to be an issue on 64-bit machines as well as 32-bit. I responded to Bug #367, but perhaps this bug is more appropriate. My configuration:

Sun Microsystems Ultra 24 (Intel Q9650)
Nvidia GeForce GT430 1GB
8GB System Memory
oi_151 dev-il with Nvidia driver 275.21

GDM starts fine and runs for a while, but ultimately locks up in the middle of performing a window action (open/close/minimize...). I can ssh in from another box and force GDM to restart, but during a period of constant use, X locks up for me every 1-2 hours.

Updated by Yan-Cheng Zhang over 2 years ago

Sorry, I have some mistyped in my post.

I have some same problem that playing Wow with wine 1.2.3,

but that 's not happens switching window only, but to run more app (firefox, termimal), even ramdomly.

at this time, can't do anything (included switch to VT) that move the curser cursor.

I 'd tried the newly driver of 280.13 (certified release), X still freezes.

148b is ok.

Updated by Ken Mays over 2 years ago

Reviewed from Bug 1268. Reviewing Nvidia 280.13 driver with oi_148b with Quadro 5000 graphics card.

The new driver handles certain crash issues with X server. I have not had a serious hang issue with this driver. There was an updated build of JDS by Guido which may not be officially in dev-il yet. Retest issue with the latest dev-il repo and JDS updates.

Updated by Albert Lee over 2 years ago

Given the similar symptoms, the root cause for some of these apparent freezes may not be in the driver, but actually a compiz-related problem shared with #1135.

Updated by Geoff Weiss over 2 years ago

All of my testing has been with the 275.21 nvidia driver.
Hardware:
intel Q9300
8GB RAM
nVidia GT430 1GB
  • oi151. 8GB RAM. X freezes during use. Both when compiz enabled and disabled
  • oi151. Only change RAM to 4GB RAM. Compiz enabled. Does not freeze.
  • oi151. Only change video to GeForce 9500 GT 1GB. Compiz enabled. Does not freeze.
  • oi148 (not illumos) and s11x 151. install svr4 275.21 nvidia driver. Compiz enabled. Does not freeze.
    (oi151 was 073011 or later version)

It looks like the freeze gets triggered by a mouse click. Pointer still moves. The screen does not change when remotely closing windowed applications. Restarting gdm SMF service or pkill -U login-uid both returns the system to a working state (my guess is because X restarts).

Updated by Ken Mays over 2 years ago

Geoff - can you confirm a crash/hang issue with oi_151's Xserver with more than 4GB RAM using the Nvidia 280.13 driver?

Updated by Geoff Weiss over 2 years ago

I was able to get the freeze with 280.13 and 8GB RAM.

The odds that this looks like to be a local hardware problem just seems to go up. I will go back and redo my earlier tests....just to make sure I didn't miss something.

Updated by Ken Mays over 2 years ago

The default oi_148b Nvidia 256.x 32-bit driver works fine with four virtual consoles being used on a HP DV laptop with Geforce Go 7600 & 2GB RAM. Compiz fully enabled. This was tested within a two-hour RECORDED desktop session.

Since dev-il was updated to 275.21, the option is to close this ticket and reference it through bugs 367,1127, & 1135. This is no longer considered a showstopper bug as it is Tier 2 status related to desktop functionality purposes - and limited to certain hardware configurations as noted by several users.

Updated by Hernán Saltiel over 2 years ago

The nVidia driver, after the image-update, is no longer freezing.
Thanks!

Updated by Ken Mays over 2 years ago

  • Due date set to 2011-09-14
  • Status changed from Feedback to Resolved
  • % Done changed from 50 to 100
  • Estimated time set to 40.00

Resolved per user's review.

Updated by Alasdair Lumsden over 2 years ago

  • Status changed from Resolved to In Progress

This is probably a duplicate of #1127 - Xorg was built with Sun Studio 12.1 instead of 12.0 which has a bug. Will respin XNV for the release.

Updated by Ken Mays over 2 years ago

  • Status changed from In Progress to Closed
  • Tags set to xnv

Closed this ticket as duplicate of Bug #1127. Please monitor that ticket for resolution.

Also available in: Atom PDF