Project

General

Profile

Bug #11637

hplip depends on old libusb library

Added by Michal Nowak 18 days ago. Updated 18 days ago.

Status:
New
Priority:
Normal
Assignee:
Category:
OI-Userland
Target version:
Start date:
Due date:
% Done:

0%

Estimated time:
Difficulty:
Medium
Tags:

Description

It seems that print/filter/hplip depends on the system/library/usb/libusb library (an old Sun fork?) instead on library/libusb-1:

{global} newman@lenovo:~ $ pkg search -r 'depend:require:system/library/usb/libusb'
INDEX      ACTION VALUE                                            PACKAGE
require    depend pkg:/system/library/usb/libusb@0.5.11-2018.0.0.1 pkg:/print/filter/hplip@3.19.5-2018.0.0.0

I try to port it to libusb-1 but don't have HW to test this.

Also available in: Atom PDF