Project

General

Profile

Actions

Bug #11684

closed

shadow compilers dislike glib2 2.62

Added by Andy Fiddaman almost 3 years ago. Updated almost 3 years ago.

Status:
Closed
Priority:
Normal
Assignee:
Category:
lib - userland libraries
Start date:
Due date:
% Done:

100%

Estimated time:
Difficulty:
Medium
Tags:
Gerrit CR:

Description

Building gate on a system which has glib2 version 2.62.0 installed fails with gcc 4.4 or smatch; the primary compiler is fine.

An example of the kinds of errors seen:

gcc 4.4.4
cc1: warnings being treated as errors
In file included from /usr/include/glib-2.0/glib/gthread.h:34,
from /usr/include/glib-2.0/glib/gasyncqueue.h:32,
from /usr/include/glib-2.0/glib.h:32,
from ../common/libpolkit-rbac.c:29:

These are because glib2 >= 2.62 suppresses warnings about deprecated declarations in header
files using pragma "GCC diagnostic ignored \"-Wdeprecated-declarations\""
This is not supported before GCC 4.6

smatch
/data/omnios-build/omniosorg/bloody/illumos/usr/src/tools/proto/root_i386-nd/opt
/onbld/bin/i386/smatch: /usr/include/glib-2.0/glib/gspawn.h:76:22: error: Expect
ed } at end of specifier

Actions

Also available in: Atom PDF