Project

General

Profile

Actions

Bug #11689

closed

::refstr would be useful

Added by John Levon almost 3 years ago. Updated over 2 years ago.

Status:
Closed
Priority:
Normal
Assignee:
Category:
-
Start date:
Due date:
% Done:

100%

Estimated time:
Difficulty:
Medium
Tags:
Gerrit CR:

Description

http://smartos.org/bugview/OS-7931

refstr_t is annoying to deal with in MDB as you have to explicitly treat the string pointer separately:

> fffffe2739d24650::print proc_t p_ct_process->conp_svc_fmri->rs_string
p_ct_process->conp_svc_fmri->rs_string = [ "s" ]
> fffffe2739d24650::print proc_t p_ct_process->conp_svc_fmri->rs_string | /s
0xfffffe23855ec348:             svc:/system/name-service-cache:default

Adding ::refstr makes this a little bit easier


Related issues

Is duplicate of illumos gate - Feature #4702: would like ::refstrDuplicate2014-03-24

Actions
Actions

Also available in: Atom PDF