Project

General

Profile

Bug #1174

fails to boot on Thinkpad T520

Added by Josef Sipek over 8 years ago. Updated over 7 years ago.

Status:
Feedback
Priority:
Normal
Assignee:
-
Category:
-
Start date:
2011-07-01
Due date:
% Done:

0%

Estimated time:
Difficulty:
Medium
Tags:
needs-triage

Description

Pretty straight forward, take a thinkpad t520 with a quad core processor, boot off the oi 148 live CD. The kernel spits out a warning in cpudrv an shortly after it reboots (a panic).

Attached are 3 photos of the relevant screens when booting with -kv.

I looked around the BIOS and found a setting to disable speedstep. Now oi 148 boots and installs just fine.


Files

IMG_20110622_174835.jpeg (1.46 MB) IMG_20110622_174835.jpeg Josef Sipek, 2011-07-01 11:32 PM
IMG_20110622_174949.jpeg (1.22 MB) IMG_20110622_174949.jpeg Josef Sipek, 2011-07-01 11:32 PM
IMG_20110622_174958.jpeg (1.45 MB) IMG_20110622_174958.jpeg Josef Sipek, 2011-07-01 11:32 PM

History

#1

Updated by Garrett D'Amore over 8 years ago

Interesting. I wonder if we have current enough ACPI tables. I have a Thinkpad W510, Core-i7 Q 820, and I don't see this, but I might have speedstep disabled.

Btw, generally we believe speedstep is not a good solution for power savings... we now think its better to "race to a lower C state".

Do you have a crash dump saved where we can look, or does this crash happen too early to collect a crash dump?

#2

Updated by Josef Sipek over 8 years ago

As far as I can tell it dies before it can dump. From the looks of things, it dies on the write to the msr itself.

How can I force a dump?

#3

Updated by Josef Sipek about 8 years ago

FWIW, I tried danmcd's acpica changes and it still dies with speedstep and works without it.

#4

Updated by Milan Jurik over 7 years ago

  • Status changed from New to Feedback

Anything new in this area? There are reports about other working T520 with the latest bits.

How fresh is BIOS on your system?

Also available in: Atom PDF