Project

General

Profile

Actions

Bug #11851

closed

ZFS special vdev ashift mismatch causes panic on removal

Added by Kody Kantor over 2 years ago. Updated over 2 years ago.

Status:
Closed
Priority:
Normal
Assignee:
Category:
zfs - Zettabyte File System
Start date:
Due date:
% Done:

0%

Estimated time:
Difficulty:
Medium
Tags:
Gerrit CR:

Description

Guenther Alka reported on the illumos-discuss mailing list that removing a special-class vdev from a pool caused the OmniOS machine to panic. The full message is here: https://illumos.topicbox.com/groups/developer/T6d8674c40f006633-Md98848d9b9998eb5024761d8/problem-with-vdev-remove-and-allocation-classes

Guenther seems to have tracked down the issue to an ashift mismatch and lack of validation on ZFS' part when removing special-class vdevs from a pool.


Related issues

Is duplicate of illumos gate - Bug #11840: Remove of a special vdev with different ashift than the pool vdevs results in an OmniOS panic/pool corrupt New

Actions
Actions #1

Updated by Gergő Mihály Doma over 2 years ago

  • Is duplicate of Bug #11840: Remove of a special vdev with different ashift than the pool vdevs results in an OmniOS panic/pool corrupt added
Actions #2

Updated by John Levon over 2 years ago

  • Status changed from New to Closed
Actions

Also available in: Atom PDF