Project

General

Profile

Actions

Bug #11920

closed

Document files with hashed names in net-snmp only exist for x86

Added by Gary Mills about 2 years ago. Updated about 1 year ago.

Status:
Closed
Priority:
Normal
Assignee:
Category:
OI-Userland
Target version:
Start date:
Due date:
% Done:

0%

Estimated time:
Difficulty:
Medium
Tags:

Description

This is the first of four bug reports for components of OI with faulty manifests. The OI source is from 2018. Some bugs may have been fixed, or there may be a new version of the source. All were developed on SPARC hardware, but the changes should not damage x86 packages. In each case, I only needed to update the manifest. The Makefile was unchanged. No new patches were needed.

While publishing sysutils/net-snmp, I received the following errors:

Couldn't find 'usr/share/doc/net-snmp/html/dir_afe752e2b61b019fd58c602c86dc4951.html' in any of the specified search directories:
...
Couldn't find 'usr/share/doc/net-snmp/html/dir_aa22c192dad6f72c562c2efe35caa225.html' in any of the specified search directories:
        .../oi-userland-apr/components/sysutils/net-snmp/net-snmp-5.7.3
        .../oi-userland/components/sysutils/net-snmp
        .../oi-userland/components/sysutils/net-snmp/build
        .../oi-userland/components/sysutils/net-snmp/build/prototype/sparc
        .../oi-userland/components/sysutils/net-snmp/build/prototype/sparc/mangled
        .../oi-userland/components/sysutils/net-snmp/build/prototype/sparcv9
gmake: *** [.../oi-userland-apr/make-rules/ips.mk:377: .../oi-userland/components/sysutils/net-snmp/build/manifest-sparc-net-snmp-documentation.depend] Error 1

The cause of this error was the files with hashed names in the manifest: they do not exist on SPARC. The solution is to append variant.arch=i386 to the missing files in the manifest. With this change, the publish operation was successful. The patch net-snmp-documentation.diff accomplishes this change.


Files

net-snmp-documentation.diff (1.67 KB) net-snmp-documentation.diff Gary Mills, 2019-11-05 01:37 AM
Actions #1

Updated by Gary Mills about 1 year ago

  • Status changed from New to Closed

Recent OI contains a new version of the net-snmp package. The manifest noted above no longer exist. This bug report will be closed.

Actions

Also available in: Atom PDF