Project

General

Profile

Bug #11944

mdb ::refcount dcmd no longer works

Added by Jason King 13 days ago. Updated 1 day ago.

Status:
Closed
Priority:
Normal
Assignee:
Category:
mdb - modular debugger
Start date:
Due date:
% Done:

100%

Estimated time:
Difficulty:
Bite-size
Tags:

Description

#10343 renamed refcount_t to zfs_refcount_t to better match what ZoL is doing. However, the ::refcount mdb dcmd was never updated, so it no longer works (it's still looking for refcount_t).


Related issues

Related to illumos gate - Bug #10343: ZoL: Prefix all refcount functions with zfs_Closed2019-02-04

Actions

History

#1

Updated by Jason King 13 days ago

  • Related to Bug #10343: ZoL: Prefix all refcount functions with zfs_ added
#2

Updated by Jason King 13 days ago

  • Description updated (diff)
#3

Updated by Electric Monk 8 days ago

  • Status changed from New to Closed
  • % Done changed from 0 to 100

git commit 0dd73f5050147fcb75220c140b5372810dcf9887

commit  0dd73f5050147fcb75220c140b5372810dcf9887
Author: Jason King <jason.king@joyent.com>
Date:   2019-11-13T18:34:58.000Z

    11944 mdb ::refcount dcmd no longer works
    Reviewed by: Sanjay Nadkarni <sanjay.nadkarni@nexenta.com>
    Reviewed by: Jerry Jelinek <jerry.jelinek@joyent.com>
    Reviewed by: Toomas Soome <tsoome@me.com>
    Approved by: Gordon Ross <gordon.w.ross@gmail.com>

#4

Updated by Joshua M. Clulow 1 day ago

Testing Notes (from Jason)

For testing, I originally hit the bug (using ‘::refcount’ in mdb would error due to lack of CTF information on ‘refcount_t’) while troubleshooting #11947. I then built a SmartOS DEBUG PI with this change and used the renamed ‘::zfs_refcount’ command (which now worked) to root cause #11947.

Also available in: Atom PDF