Project

General

Profile

Bug #11970

/hipster: python 3.4 dependecies to be fixed

Added by Predrag Zečević 5 months ago. Updated 26 days ago.

Status:
Resolved
Priority:
Normal
Category:
-
Target version:
Start date:
Due date:
% Done:

0%

Estimated time:
Difficulty:
Medium
Tags:

Description

Hi all,

:; pkg mediator | grep -E "MEDIATOR|python" 
MEDIATOR            VER. SRC. VERSION IMPL. SRC. IMPLEMENTATION
python              vendor    2.7     vendor     
python3             system    3.5     system     

When tried to remove python 3.4 packages:

:; pkg uninstall: Unable to remove 'runtime/python-34@3.4.10-2018.0.0.0' due to the following packages that depend on it:
  backup/borg-34@1.1.10-2019.0.0.0
  gnome/accessibility/orca@3.24.0-2018.0.0.0
  library/desktop/libpeas@1.20.0-2018.0.0.1
  web/server/apache-24/module/apache-wsgi-34@4.5.22-2018.0.0.2
  x11/redshift@1.12-2018.0.0.1

I guess some packages need rebuilding

Regards.

P.S: Obvious packages list (with python in name) are attached.


Files

python-34.packages.txt (5.62 KB) python-34.packages.txt python 3.4 related packages list ... Predrag Zečević, 2019-11-13 10:42 AM

History

#1

Updated by Alexander Pyhalov 26 days ago

  • Assignee set to Alexander Pyhalov
  • Status changed from New to Resolved

Borg now has borg-35 version. Orca and redshift were switched to Python 3.5. apache wsgi 3.4 module can be uninstalled. Libpeas now uses Python 3.5 to build Python 3 plugins.

Also available in: Atom PDF