Project

General

Profile

Bug #12019

last samba update does not provide 32-bit nss_winbind

Added by vanni della 3 months ago. Updated 3 days ago.

Status:
Resolved
Priority:
Normal
Category:
OI-Userland
Target version:
Start date:
Due date:
% Done:

0%

Estimated time:
Difficulty:
Medium
Tags:

Description

Hi,
we have update hippster at latest update and we found that nss_winbind dosn't works. testing some commands with truss i' found that on new samba package library nss_winbind.so at 32bit is missing and nss_winbind at 64bit dosen't work with command id, ls, ecc ecc.

History

#1

Updated by Michal Nowak 3 months ago

vanni della della: Samba is now 64-bit-only. Is there a reproducer showing what's wrong? What's the error message?

#2

Updated by Michal Nowak 3 months ago

Rouven might know better than I do what might went wrong.

#3

Updated by vanni della 3 months ago

the problem is that actualy winbind nss not working correctly. I have setup an fileserver whit OI hipster in Active directory environment. nsswitch conf is config as same:

passwd: files winbind
group: files winbind

In original setup it work, it was possible to see resolved UID and GID from Active Directory. With last samba no. i 've try to copie file in /usr/lib/samba/amd64/nss_winbind.so.1 in /usr/lib but library is a 64bit. using truss for trace systems call return this error:

....
resolvepath("/usr/lib/nss_winbind.so.1", "/usr/lib/nss_winbind.so.1", 1023) = 25
open("/usr/lib/nss_winbind.so.1", O_RDONLY) = 4
mmapobj(4, MMOBJ_INTERPRET, 0xFEF60808, 0x080405AC, 0x00000000) Err#48 ENOTSUP
mmap(0x00000000, 4096, PROT_READ, MAP_PRIVATE, 4, 0) = 0xFEF40000
...
in oldest boot environment samba installed a valid nss_windbind.so (32bit) in /usr/lib

#4

Updated by Michal Nowak 2 months ago

Can it be that portions of the OS are still 32-bit-only and therefore does not play along with 64-bit Samba?

#5

Updated by vanni della 2 months ago

This is an my supposition, reached by compared old boot environment.

#6

Updated by Alexander Pyhalov 3 days ago

  • Subject changed from last samba update not provides nss_winbind at 32bit to last samba update does not provides nss_winbind at 32bit
#7

Updated by Alexander Pyhalov 3 days ago

  • Subject changed from last samba update does not provides nss_winbind at 32bit to last samba update does not provide 32-bit nss_winbind
#8

Updated by Alexander Pyhalov 3 days ago

  • Category changed from PKG (Image Packaging System) to OI-Userland
  • Status changed from New to Resolved
  • Assignee changed from OI PKG to Alexander Pyhalov

Also available in: Atom PDF