Project

General

Profile

Actions

Bug #12037

closed

ptree zone handling is broken

Added by John Levon about 2 years ago. Updated almost 2 years ago.

Status:
Closed
Priority:
Normal
Assignee:
Category:
-
Start date:
Due date:
% Done:

100%

Estimated time:
Difficulty:
Medium
Tags:
Gerrit CR:

Description

Since:

11906 Add line drawing characters to ptree(1)

ptree zone handling is broken.
The problem is that proc_walk is defined not to iterate on SSYS procs. But this
means we don't include zone's "zsched" processes. As a result, all zone processes
end up as orphaned children of proc0, and are therefore ignored unless -a is also specified.

This can hopefully be fixed by adding a PROC_WALK_SYS flag to proc_walk().


Related issues

Related to illumos gate - Feature #11906: Add line drawing characters to ptree(1)ClosedJason King

Actions
Actions

Also available in: Atom PDF